Bug 1310256 - ndoutils is out of sync with nagios package [NEEDINFO]
ndoutils is out of sync with nagios package
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ndoutils (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-19 16:44 EST by Ronald Roskens
Modified: 2016-04-22 15:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: ndoutils-2.0.0-11.fc23 ndoutils-2.0.0-11.fc22 ndoutils-2.0.0-11.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 21:26:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
negativo17: needinfo? (ronald.roskens)


Attachments (Terms of Use)

  None (edit)
Description Ronald Roskens 2016-02-19 16:44:20 EST
Description of problem:
Nagios was updated to 4.0.x in EPEL 7. Attempting to run ndoutils with it results in multiple failures.

Version-Release number of selected component (if applicable):
nagios 4.0.8-2.el7
ndoutils 2.0.0-7.el7

How reproducible:
always

Steps to Reproduce:
1. install nagios
2. install ndoutils
3. enable ndomod in nagios.cfg
4. systemctl start nagios

Actual results:
Nagios fails to start, and logs in /var/log/nagios/nagios.log:
[1455910433] Error: Could not load module '/usr/lib64/nagios/brokers/ndomod.so' -> /usr/lib64/nagios/brokers/ndomod.
so: undefined symbol: hostdependency_list
[1455910433] Error: Failed to load module '/usr/lib64/nagios/brokers/ndomod.so'.
[1455910433] Error: Module loading failed. Aborting.


Expected results:
success

Additional info:
The ndo2db.service attempts to create a unix socket file under /var/run/ndoutils/, but that fails because /var/run/ndoutils is owned by root.

The ndo2db.service just needs two additional lines:
PermissionsStartOnly=true
RuntimeDirectory=ndoutils

and then it will create the directory with the appropriate permissions.
Comment 1 Simone Caronni 2016-02-23 09:34:00 EST
Hello,

(In reply to Ronald Roskens from comment #0)
> [1455910433] Error: Could not load module
> '/usr/lib64/nagios/brokers/ndomod.so' -> /usr/lib64/nagios/brokers/ndomod.
> so: undefined symbol: hostdependency_list

actually the package was still built for Nagios 3.x, I did not know it was rebased. Unfortunately I don't have acces to an Nagios/NDOutils installation anymore.

I've updated the SPEC file and now links as follows:

- Nagios 2.x - epel5 (if rebuilt, as epel6 still has ndoutils 1.5.2)
- Nagios 3.x - epel6
- Nagios 4.x - epel7, f22+

Can you make a test with the following build?

http://koji.fedoraproject.org/koji/buildinfo?buildID=738274

If it still doesn't work, I will add the 2 lines you've pointed out in the last comment to the systemd unit file.

Thanks,
--Simone
Comment 2 e.rissel 2016-03-08 04:49:31 EST
Hi,
I stumbled against this very same problem, having :

Could not load module '/usr/lib64/nagios/brokers/ndomod.so' -> /usr/lib64/nagios/brokers/ndomod.so: undefined symbol: hostdependency_list

when trying to start nagios with ndoutils on.

I added :
" The ndo2db.service just needs two additional lines:
" PermissionsStartOnly=true
" RuntimeDirectory=ndoutils

but still got error and couldn't start nagios.

Then I installed the rpm from
http://koji.fedoraproject.org/koji/buildinfo?buildID=738274

Restarted Nagios and it work, here is the output from nagios.log :

[1457429849] Nagios 4.0.8 starting... (PID=6219)
[1457429849] Local time is Tue Mar 08 10:37:29 CET 2016
[1457429849] LOG VERSION: 2.0
[1457429849] qh: Socket '/var/spool/nagios/cmd/nagios.qh' successfully initialized
[1457429849] qh: core query handler registered
[1457429849] nerd: Channel hostchecks registered successfully
[1457429849] nerd: Channel servicechecks registered successfully
[1457429849] nerd: Channel opathchecks registered successfully
[1457429849] nerd: Fully initialized and ready to rock!
[1457429849] wproc: Successfully registered manager as @wproc with query handler
[1457429849] wproc: Registry request: name=Core Worker 6220;pid=6220
[1457429849] wproc: Registry request: name=Core Worker 6221;pid=6221
[1457429849] wproc: Registry request: name=Core Worker 6222;pid=6222
[1457429849] wproc: Registry request: name=Core Worker 6223;pid=6223
[1457429849] ndomod: NDOMOD 2.0.0 (02-28-2014) Copyright (c) 2009 Nagios Core Development Team and Community Contributors
[1457429849] ndomod: Could not open data sink!  I'll keep trying, but some output may get lost...
[1457429849] ndomod registered for process data
[1457429849] ndomod registered for timed event data
[1457429849] ndomod registered for log data'
[1457429849] ndomod registered for system command data'
[1457429849] ndomod registered for event handler data'
[1457429849] ndomod registered for notification data'
[1457429849] ndomod registered for service check data'
[1457429849] ndomod registered for host check data'
[1457429849] ndomod registered for comment data'
[1457429849] ndomod registered for downtime data'
[1457429849] ndomod registered for flapping data'
[1457429849] ndomod registered for program status data'
[1457429849] ndomod registered for host status data'
[1457429849] ndomod registered for service status data'
[1457429849] ndomod registered for adaptive program data'
[1457429849] ndomod registered for adaptive host data'
[1457429849] ndomod registered for adaptive service data'
[1457429849] ndomod registered for external command data'
[1457429849] ndomod registered for aggregated status data'
[1457429849] ndomod registered for retention data'
[1457429849] ndomod registered for contact data'
[1457429849] ndomod registered for contact notification data'
[1457429849] ndomod registered for acknowledgement data'
[1457429849] ndomod registered for contact status data'
[1457429849] ndomod registered for adaptive contact data'
[1457429849] Event broker module '/usr/lib64/nagios/brokers/ndomod.so' initialized successfully.
[1457429849] Successfully launched command file worker with pid 6224

CentOS Linux release 7.2.1511 (Core) 
nagios 4.0.8-2.el7
ndoutils 2.0.0-11.el7
mariadb 5.5.44-2.el7.centos

did not test the rpm without the 2 lines in ndo2db.service (can test it if you want)
Comment 3 Simone Caronni 2016-03-08 09:10:09 EST
(In reply to e.rissel from comment #2)
> Could not load module '/usr/lib64/nagios/brokers/ndomod.so' ->
> /usr/lib64/nagios/brokers/ndomod.so: undefined symbol: hostdependency_list
> 
> when trying to start nagios with ndoutils on.
> 
> I added :
> " The ndo2db.service just needs two additional lines:
> " PermissionsStartOnly=true
> " RuntimeDirectory=ndoutils
> 
> but still got error and couldn't start nagios.
> 
> Then I installed the rpm from
> http://koji.fedoraproject.org/koji/buildinfo?buildID=738274
> 
> Restarted Nagios and it work, here is the output from nagios.log :
[...]
> CentOS Linux release 7.2.1511 (Core) 
> nagios 4.0.8-2.el7
> ndoutils 2.0.0-11.el7
> mariadb 5.5.44-2.el7.centos
> 
> did not test the rpm without the 2 lines in ndo2db.service (can test it if
> you want)

Yes please, if you can test without the lines (as the package is built) it would be great. As you've seen, the missing symbol is due to the old ndoutils package still built againts Nagios 3.x, before the rebase.

I don't think the two lines in the unit file are needed.
Comment 4 Fedora Update System 2016-04-01 10:57:30 EDT
ndoutils-2.0.0-11.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9021f07c58
Comment 5 Fedora Update System 2016-04-01 10:57:35 EDT
ndoutils-2.0.0-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6abc4263fb
Comment 6 Fedora Update System 2016-04-01 10:57:39 EDT
ndoutils-2.0.0-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-7be925b558
Comment 7 Fedora Update System 2016-04-02 01:20:48 EDT
ndoutils-2.0.0-11.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9021f07c58
Comment 8 Fedora Update System 2016-04-02 01:26:02 EDT
ndoutils-2.0.0-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6abc4263fb
Comment 9 Fedora Update System 2016-04-02 04:50:27 EDT
ndoutils-2.0.0-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-7be925b558
Comment 10 Fedora Update System 2016-04-21 21:25:59 EDT
ndoutils-2.0.0-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-04-21 21:51:36 EDT
ndoutils-2.0.0-11.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-04-22 15:58:53 EDT
ndoutils-2.0.0-11.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.