Bug 1310357 - Anaconda reports missing treeinfo and I can't find ARM repo for Trimslice with one, Fedora 22 or 23
Anaconda reports missing treeinfo and I can't find ARM repo for Trimslice wit...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
22
armv7l Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-20 17:35 EST by Patrick Daly
Modified: 2016-02-23 11:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 09:18:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Daly 2016-02-20 17:35:53 EST
Description of problem:

Started here:
https://fedoraproject.org/wiki/Architectures/ARM/F23/Installation

Used USB since web page says MMC has a problem can't be used on Trimslice
Updated the firmware for Device Tree as it says to do.
Set the env vars as it says.
Tried Fedora-KDE-armhfp-23-10-sda.raw.xz but gives disk read error
so switched to Fedora 22 as follows...

Working with this now:
https://fedoraproject.org/wiki/Architectures/ARM/F22/Installation

This image Fedora-KDE-armhfp-22-3-sda.raw.xz boots and gets me to login.
The doc is not clear (to me) on where to go from here, so I *assume* anaconda
should be run so that's what I'm trying to do.  I'm not upgrading Fedora,
I'm trying to install over Ubuntu.

Graphics terminal not working, so using the serial console with mincom.
(I have a feeling DVI support is not included with opentegra ?)
So I'm using text mode with anaconda.

First problem seems to be with a bad URL, so I tried changing as follows:
[root@pdaly-slice ~]# diff anaconda-ks.cfg.ORIG anaconda-ks.cfg  
9c9
< repo --name="koji-override-0" --baseurl=http://infrastructure.fedoraproject.org/pub/fedora/linux/development/22/armhfp/os/
---
> repo --name="koji-override-0" --baseurl=http://dl.fedoraproject.org/pub/fedora/linux/development/22/armhfp/os/

Not sure that will work, but....

Next problem is missing "treeinfo" which after hours I happened to see mentioned in a 
log file and after some more searching found that it's a "dot" file. I assumed it a 
descriptive term, but it literally means it's looking for that file of that name. 

Then I tried various repo's searching for 22/armhfp/os.  I was using the text interface
to specify Network (which is up and running) and I put http:// in front of the URL.
anaconda is already adding that prefix itself and in one of the logs I see it being removed
and a server lookup done on the extra "http://" which gives a "server not found" or some such.
So I starting trying repo URL's without the prefix. 
But the big problem is I can't find a Fedora 22 (or 23) repo with a treeinfo file.

Although I'm booted to the Fedora-KDE-armhfp-22, I though it might
be possible to use a 23 repo and install 23 as I wanted to in the first place.
But I can't find a 23 repo with a treeinfo file either.

To date, I've been installing Fedora on my intel workstation at home
with a DVD install that someone gives me and that was painless... just
boot it and off it goes.  But I'm burning out trying to get this ARM install working. 
Please help....

Version-Release number of selected component (if applicable):
23 image gave me disk read error, 22 has problems in description above.

How reproducible:
(see description)

Steps to Reproduce:
1.(see description)
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Shea 2016-02-22 09:18:23 EST
Red Hat Bugzilla is not an avenue for technical assistance or support, but simply a bug tracking system. https://fedoraproject.org/wiki/Communicating_and_getting_help has more information on where to find assistance with installing Fedora. In particular, the #fedora-arm IRC channel on freenode.net may be able to provide help.
Comment 2 Patrick Daly 2016-02-22 12:03:20 EST
Okay, I guess I shouldn't have written this up as a narrative, but I *think*
there's at least one or two issues I mentioned that could be called bugs.
(1) anaconda-ks.cfg in the F22 image has a repo URL (1st one) that gives a 403 error
(2) The F22 image boots and comes up but the F23 image gives a read error for me
    and since I'm making both the same way (per cited Installation URL) I don't
    know what to think other than it's a bad image.
    

That URL you cited tells us to use Bugzilla for bugs and enhancements:
https://fedoraproject.org/wiki/Communicating_and_getting_help
Says:
    "Providing Feedback to Developers
     If you believe you have found a bug or would
     like to suggest enhancements, use the Bugzilla bug tracking system."

Relative to the above statement. I mentioned that the install adds a "http://"
to what you type in for a URL and treats the second "http://" as the address 
where the repo can be found.  The install should either reject what you type 
saying don't add "http://" or it should see it's already there and not add another.
Is a bug fix or enhancement needed? 

A general problem with the install is a when you specify sources and something
is wrong it says some generic like "Error getting sources".  Maybe an enhancement
could be to give a bit more detail as to what's wrong.  

So.... 
Is there anything in my previous post that can be considered a bug and 
split out? 

I would be happy to see an anaconda-ks.cfg for this ARM install with the right
repo's because it appears that are pretty specific. Here are the ones from the
F22 anaconda-ks.cfg (since F23 doesn't run for me).  The first gives a 403 error:
repo --name="koji-override-0" --baseurl=http://infrastructure.fedoraproject.org/pub/fedora/linux/development/22/armhfp/os/
repo --name="koji-override-1" --baseurl=http://kojipkgs.fedoraproject.org/mash/bleed/armhfp/
Comment 3 David Shea 2016-02-22 12:52:56 EST
(In reply to Patrick Daly from comment #2)
> Okay, I guess I shouldn't have written this up as a narrative, but I *think*
> there's at least one or two issues I mentioned that could be called bugs.
> (1) anaconda-ks.cfg in the F22 image has a repo URL (1st one) that gives a
> 403 error

The image you're referring to is not an installer environment. It is a complete Fedora installation intended to be written to your target media, and once that's done, you just boot to it and run from there. The file in /root/anaconda-ks.cfg is generated from the settings that were used to create the image. When that image was create it was apparently using a development URL.

> Relative to the above statement. I mentioned that the install adds a
> "http://"
> to what you type in for a URL and treats the second "http://" as the address 
> where the repo can be found.  The install should either reject what you type 
> saying don't add "http://" or it should see it's already there and not add
> another.
> Is a bug fix or enhancement needed? 

Text mode could probably use some work as far as URL validation, yes. But, I just tried this, using http:// as the protocol and http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/ as the URL, and that worked fine. This may have been fixed in the nine months since Fedora 22 was released.

> A general problem with the install is a when you specify sources and
> something
> is wrong it says some generic like "Error getting sources".  Maybe an
> enhancement
> could be to give a bit more detail as to what's wrong.  

Much of that information is buried in dnf. We have been working to create more descriptive error messages but it is not a high priority.
Comment 4 Patrick Daly 2016-02-22 14:52:16 EST
The image I'm referring to is to be written by dd to a media then inserted
into the target system's media slot (SD/MMC slot or USB slot) and booted:

https://fedoraproject.org/wiki/Architectures/ARM/F22/Installation
says as follows:
"The image-based installation process involves downloading an image file (depending upon desktop/non-desktop option desired), inserting removable media into a "host" system (e.g. an ARM or x86_64 PC class desktop, laptop, etc.) and performing a few simple commands to write this image onto the media. This media is then used by the ARM "target" system to boot the Fedora 22 environment.
After writing the image and correct U-boot file(s), insert the media into the target platform and boot."


xzcat Fedora-KDE-armhfp-22-3-sda.raw.xz | dd of=/dev/sda ; sync

At the above URL, there's various commands by platform to "Write U-Boot to Media".
The TrimSlice is different in that it doesn't need the boot on the media.
Instead of the 2 or 3 commands to do this write to media, it says:
"The Trimslice requires no additional steps, U-Boot is included on the device."

The TrimSlice has a 32 Gig internal SSD (which has Ubuntu and I want to 
replace that with Fedora 22 or 23).  The other internal device is the SPI flash which holds uBoot.... this is why the doc says "U-Boot is included on the device."

When the TrimSlice boots, it looks for a valid /boot.scr in this order

    Front SD card  <--- The F22/23 install at URL says don't use due to timeout bug 
    External USB storage <--- THIS IS WHERE stick with Fedora-KDE-armhfp-22-3-sda.raw inserted
    Micro-SD card <--- (not using for install)
    Internal 32 Gig SSD  <--- This is the install target (currently Ubuntu)



So when the TrimSlice is booted, it sees the image Fedora-KDE-armhfp-22-3-sda.raw 
on the USB stick and boots it.   If you reboot without the USB it finds Ubuntu on the SSD,
i.e. the booted Fedora on USB does not automatically write anything to the SSD drive.
Nor does it bring up an install procedure.  It simply boots to login prompt and that's it:

((( boot spew deleted )))
[  OK  ] Started Permit User Sessions.
         Starting Terminate Plymouth Boot Screen...
[  OK  ] Started Command Scheduler.
         Starting Command Scheduler...
         Starting Wait for Plymouth Boot Screen to Quit...
[   34.152030] vgaarb: this pci device is not a vga device
[   34.177454] vgaarb: this pci device is not a vga device

Fedora release 22 (Twenty Two)
Kernel 4.0.4-301.fc22.armv7hl on an armv7l (ttyS0)

localhost login: root
Password: 

[root@pdaly-slice ~]# df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        474M     0  474M   0% /dev
tmpfs           502M     0  502M   0% /dev/shm
tmpfs           502M  752K  501M   1% /run
tmpfs           502M     0  502M   0% /sys/fs/cgroup
/dev/sdb3       4.5G  4.4G   33M 100% /               <-------- THIS IS MY 16 Gig USB stick
/dev/sdb1       457M  194M  259M  43% /boot           <-------- with Fedora-KDE-armhfp-22-3-sda
tmpfs           101M     0  101M   0% /run/user/990
tmpfs           101M     0  101M   0% /run/user/0


****** HERE in /root I AM TRYING TO RUN THE anaconda INSTALL TO WRITE TO SSD:**************

[root@pdaly-slice ~]# pwd 
/root

[root@pdaly-slice ~]# ls 
anaconda23-ks.cfg     Documents  initial-setup-ks.cfg  Templates
anaconda-ks.cfg       Downloads  Music                 Videos
anaconda-ks.cfg.ORIG  foo        Pictures              xorg.conf.new
Desktop               foo.ana    Public                zmnt

***** HERE IS A PEEK AT THE TARGET SSD DRIVE...     *****
***** It's intact with Ubuntu after the boot of Fedora from USB *****
***** This is why I am trying to run anaconda from the USB Fedora 22 system *****

[root@pdaly-slice ~]# mount /dev/sda1 /zmnt

[root@pdaly-slice ~]# df -h /zmnt
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda1        30G   18G  9.9G  65% /zmnt    <----- 32 Gig internal SSD

[root@pdaly-slice ~]# cat /zmnt/etc/issue
Ubuntu 12.04.5 LTS \n \l
============================================================


> But, I just tried this, using http:// as the protocol 
> and http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/

The problem is I don't know where to find an ARM repo that works after a couple of days
of looking around.  I've been using the two inside anaconda-ks.cfg as a hint 
as to what ARM depots to look for.   

repo --name="koji-override-0" --baseurl=http://infrastructure.fedoraproject.org/pub/fedora/linux/development/22/armhfp/os/
repo --name="koji-override-1" --baseurl=http://kojipkgs.fedoraproject.org/mash/bleed/armhfp/

The first is unreadable to me:
"Forbidden
You don't have permission to access /pub/fedora/linux/development/22/armhfp/os/ on this server."


Yeah, but the other problem I forgot to mention is when "repodata" is missing the 
install doesn't work because it insists that it be there.  Your x86_64 URL has repodata
but many I look at (ARM or X86) are missing repodata.
Comment 5 Patrick Daly 2016-02-22 15:04:14 EST
Oopps.. I meant missing "treeinfo" not "repodata"... and I did mention it... it's in the headline.
Comment 6 Martin Kolman 2016-02-22 15:17:04 EST
(In reply to Patrick Daly from comment #4)

<snip>

> Yeah, but the other problem I forgot to mention is when "repodata" is
> missing the 
> install doesn't work because it insists that it be there.  Your x86_64 URL
> has repodata
> but many I look at (ARM or X86) are missing repodata.

Yet again - *you don't install* from the arm image - you just dd it to the card and boot from it. That's it.

I think the ARM installation instructions are pretty clear about this:

https://fedoraproject.org/wiki/Architectures/ARM/F23/Installation#Download_the_Disk_Image_.26_Copy_to_Media

The repo URL and kickstart are just image generation side-effects.
Comment 7 Paul Whalen 2016-02-22 15:31:45 EST
To install to the SSD you would need to dd the image to the SSD (perhaps while running from USB). 

http://dl.fedoraproject.org/pub/fedora/linux/releases/22/Server/armhfp/os/.treeinfo

Suggest dropping by #fedora-arm on Freenode for some assistance.
Comment 8 Patrick Daly 2016-02-22 17:11:42 EST
(In reply to Martin Kolman from comment #6)
> (In reply to Patrick Daly from comment #4)
> 
> <snip>
> 
> > Yeah, but the other problem I forgot to mention is when "repodata" is
> > missing the 
> > install doesn't work because it insists that it be there.  Your x86_64 URL
> > has repodata
> > but many I look at (ARM or X86) are missing repodata.
> 
> Yet again - *you don't install* from the arm image - you just dd it to the
> card and boot from it. That's it.
> 
> I think the ARM installation instructions are pretty clear about this:
> 
> https://fedoraproject.org/wiki/Architectures/ARM/F23/
> Installation#Download_the_Disk_Image_.26_Copy_to_Media

Well, there's my confusion.    It really *is* the end of the road....
 
I did think days ago that the install instructions just dead-ended.  
I have Ubuntu on the internal 32 Gig drive and want to replace 
it with Fedora.  The instructions tell you to put the Fedora image on a
(USB in TrimSlice case since SD has a problem) and says:

"This media is then used by the ARM 'target' system to boot 
the Fedora 23 environment." 

Well, okay.... 

I half-expected  an installer to then come up and see the SSD and ask 
if I wanted to install on it.  At this point I have Fedora running on 
a USB stick hanging out of the front the TrimSlice and want to get it
onto the SSD. 

So from this point I was searching for a really long time on how to 
proceed from here.

> 
> The repo URL and kickstart are just image generation side-effects.

I see. When I saw the kickstart file in the USB /root I figured maybe I'm 
expected to run anaconda to get the Fedora on the big drive. 

Thanks.
Comment 9 Patrick Daly 2016-02-22 17:18:49 EST
(In reply to Paul Whalen from comment #7)
> To install to the SSD you would need to dd the image to the SSD (perhaps
> while running from USB). 

Okay, understand.  
As I said in response to Martin, I was thinking I needed to run 
an installer since one didn't come up automatically.   And that 
installer would sense what's there for hardware, help configure, etc. 

> 
> http://dl.fedoraproject.org/pub/fedora/linux/releases/22/Server/armhfp/os/.
> treeinfo
> 
> Suggest dropping by #fedora-arm on Freenode for some assistance.

Thanks.
Comment 10 Martin Kolman 2016-02-23 09:01:25 EST
> > 
> > The repo URL and kickstart are just image generation side-effects.
> 
> I see. When I saw the kickstart file in the USB /root I figured maybe I'm 
> expected to run anaconda to get the Fedora on the big drive. 

I actually have a patch almost ready that makes it easy to prevent image generation artifacts like this one from reaching the image. :)


(In reply to Patrick Daly from comment #9)
> (In reply to Paul Whalen from comment #7)
> > To install to the SSD you would need to dd the image to the SSD (perhaps
> > while running from USB). 
> 
> Okay, understand.  
> As I said in response to Martin, I was thinking I needed to run 
> an installer since one didn't come up automatically.   And that 
> installer would sense what's there for hardware, help configure, etc. 

I *think* that it is done like this because many arm boards have just a single storage device and/or generally have limited support for booting from external devices. So you just dd the image on the storage you have and run from it.

But someone with more knowledge of Fedora on the ARM platform might want to correct me. :)
Comment 11 Patrick Daly 2016-02-23 11:04:07 EST
(In reply to Martin Kolman from comment #10)
> > > 
> > > The repo URL and kickstart are just image generation side-effects.
> > 
> > I see. When I saw the kickstart file in the USB /root I figured maybe I'm 
> > expected to run anaconda to get the Fedora on the big drive. 
> 
> I actually have a patch almost ready that makes it easy to prevent image
> generation artifacts like this one from reaching the image. :)

Nice!  :-) 

> (In reply to Patrick Daly from comment #9)
> > (In reply to Paul Whalen from comment #7)
> > > To install to the SSD you would need to dd the image to the SSD (perhaps
> > > while running from USB). 
> > 
> > Okay, understand.  
> > As I said in response to Martin, I was thinking I needed to run 
> > an installer since one didn't come up automatically.   And that 
> > installer would sense what's there for hardware, help configure, etc. 
> 
> I *think* that it is done like this because many arm boards have just a
> single storage device and/or generally have limited support for booting from
> external devices. So you just dd the image on the storage you have and run
> from it.
> 
> But someone with more knowledge of Fedora on the ARM platform might want to
> correct me. :)

While running Fedora on the ARM's USB, I'm going to dd the image from
my x86 (i.e. not dd a running system) to the ARM's big drive (SSD) 
then run "gparted" on the SSD from the USB which the doc says can 
expand the file system to fill the drive (SSD).

Note You need to log in before you can comment on or make changes to this bug.