Bug 1310465 - Consider sending patches upstream
Consider sending patches upstream
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: agg (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 17:26 EST by Elliott Sales de Andrade
Modified: 2016-04-05 14:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-05 14:27:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliott Sales de Andrade 2016-02-21 17:26:46 EST
Description of problem:
The Agg package is currently holding on to 18 patches based on the 2.5 release. However, there is a reasonably-active upstream based around the 2.4 release here [1], though for some reason they use the previous project's mailing list [2].

Matplotlib 1.5.1 has rebased their bundled agg to a svn checkout instead of 2.4 on this upstream's advice. I have not tested out the differences, but it is likely that results would differ if moving back to the released version.

This patching scenario is probably not good for anybody, most of all the packagers, so please consider sending these patches to the new upstream.

I would be willing to help facilitate the discussion, but the first matter in question is the license. 2.5 is GPL, while the 2.4 line is BSD and hence would not be able to accept the pactches as-is. However, the codebase in Mapnik itself does seem to mark Agg as the BSD-licensed 2.4 line, so I am a bit confused about the status of these patches. Was there any clarification made on the patch license when they were incorporated? Should I go ask Mapnik developers?


Version-Release number of selected component (if applicable):
agg-2.5-23.fc23.x86_64

Additional info:
[1] https://sourceforge.net/p/agg/svn/HEAD/tree/
[2] https://sourceforge.net/p/vector-agg/mailman/vector-agg-general/
Comment 1 Gwyn Ciesla 2016-03-01 11:05:22 EST
CCing tom@compton.nu, Tom, what is the origin of these patches?  I don't recall.
Comment 2 Tom Hughes 2016-03-01 11:24:48 EST
They came from mapnik (https://github.com/mapnik/mapnik) which has a bundled copy of agg.

There are many, many more changes now in the mapnik copy and I actually gave up any idea of trying to extract them all into the Fedora libagg and and am now (given the change in bundling policy) using the bundled version for mapnik.

The original import of agg to mapnik was https://github.com/mapnik/mapnik/commit/d8dc53bcf435802227fcde1134df05acdd33106b but that doesn't seem to be an exact match for the released 2.4 source even though it was committed shortly after the release. My guess is that it's a snapshot from sometime before 2.4 was released.
Comment 3 Gwyn Ciesla 2016-03-01 11:49:05 EST
Ok, that makes sense.  Adding thomas.spura@gmail.com, python-matplotlib maintainer.

I don't see anything else using this agg RPM, and since both python-matplotlib and mapnik use heavily modified bundled aggs, though I loathe bundling, this seems like the best case, and there's not reason not to retire this RPM once python-matplotlib is updated to 1.5.1 and use bundled agg.

Objections, suggestions?
Comment 4 Tom Hughes 2016-03-01 14:13:31 EST
Fine by me.
Comment 5 Elliott Sales de Andrade 2016-03-02 01:41:18 EST
I've been hoping to send as many patches upstream as possible, but as yet have not heard back from the new maintainer (who seems in-and-out...)
Comment 6 Gwyn Ciesla 2016-04-05 14:27:18 EDT
Retired.

Note You need to log in before you can comment on or make changes to this bug.