Bug 1310490 - Network Time Servers set in anaconda do not appear under system-config-date after install
Network Time Servers set in anaconda do not appear under system-config-date a...
Status: CLOSED DUPLICATE of bug 1377121
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-21 20:48 EST by Jia Yuan Lo
Modified: 2016-10-14 11:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 11:46:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jia Yuan Lo 2016-02-21 20:48:28 EST
Description of problem:
system-config-date UI works as expected however the underlying usage of ntp daemon did not installed at all

Version-Release number of selected component (if applicable):
Maybe across all versions?

How reproducible:
On a fresh MATE-Compiz 23 live DVD which does not have ntp installed, system-config-date doesn't even produce an error that ntp is not installed
UI still proceed to work but the synchronisation of time do not as intended

Steps to Reproduce:
As above

Actual results:
system-config-date failed to notice ntp is not installed in the system and UI works even though the function to sync time does not work

Expected results:
system-config-date should report the error and disable the sync feature or just exit as a whole until user install ntp and related packages

Additional info (for MATE team):
Also please call in the MATE SIG team to have ntp (as well as other packages) included in next spin release
Possibly referring the Server 23 DVD or the Fedora 20 Multi DVD for missing packages
Comment 1 Corey Sheldon 2016-02-22 06:58:32 EST
I uses chrony, hence  does not care about or fail out on lack of ntp.
Comment 2 Jia Yuan Lo 2016-02-22 08:33:03 EST
Hmm... I must have miss the point that chrony is now default daemon for syncing time.

Ok, maybe the bug's focus need to be change a little (or maybe closed).

The thing is that I notice that configuration that was made in anaconda such as adding an ntp server other than fedora.pool.ntp.org and after install it will not end up at system-config-date.

Ok I will change the title to reflect the change of focus from missing ntp package to anaconda improper configuration of network time syncing...
Comment 3 David Shea 2016-02-22 09:20:21 EST
(In reply to Jia Yuan Lo from comment #2)
> Hmm... I must have miss the point that chrony is now default daemon for
> syncing time.

That was five years ago. https://fedoraproject.org/wiki/Features/ChronyDefaultNTP

> Ok I will change the title to reflect the change of focus from missing ntp
> package to anaconda improper configuration of network time syncing...

Anaconda is configuring chrony just fine, in chrony.conf.
Comment 4 Jia Yuan Lo 2016-02-22 10:05:46 EST
Ok I can confirm anaconda does add the network time servers to /etc/Chrony.conf

But system-config-date do not show the added servers...

/.\ I think I getting very exhausting right now.

So this is system-config-date fault or is the default by design (not showing network time servers from anaconda)?
Comment 5 Nils Philippsen 2016-07-29 13:48:58 EDT
Sorry for the late reply.

System-config-date should detect chrony and use /etc/chrony.conf if present. Do you still have this issue? Can you run it from the command line and see if there are any error messages?
Comment 6 Jia Yuan Lo 2016-07-30 12:27:14 EDT
ah yes, I also forget about this...

anyway back then is somewhat confusing but what I am trying to say is this line

pool 2.fedora.pool.ntp.org iburst

inside default /etc/chrony.conf is not showing up in system-config-date...

For example, only servers added later on in system-config-date will show up themselves in the form of

server sg.pool.ntp.org

I am not implying the sync is not working, just that 2.fedora.pool.ntp.org configured by anaconda seems to be ignored by system-config-date but syncing still works...
Comment 7 Nils Philippsen 2016-10-14 11:46:11 EDT
Hi!

I don't actively develop system-config-date anymore, i.e. I don't have the time to work on this feature myself. I've announced this on the Fedora devel list a couple of weeks ago(*) but so far nobody has come forth who'd pick up this package. Accordingly, I'll close this bug as a duplicate of the feature request to support pool directives.

(*): https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/BIV6Z2LN2LCO4I6LE636PPWOINUETV3S/

*** This bug has been marked as a duplicate of bug 1377121 ***

Note You need to log in before you can comment on or make changes to this bug.