Bug 1310511 - About patch "aio: strengthen memory barriers for bottom half scheduling"
About patch "aio: strengthen memory barriers for bottom half scheduling"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.1
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
: 1356849 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 00:06 EST by Yuki Shibuya
Modified: 2016-07-18 10:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 12:39:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuki Shibuya 2016-02-22 00:06:51 EST
Description of problem:

We recently faced the problem mentioned in below patch on other distribution.
And our problem was solved by this patch.

http://git.qemu.org/?p=qemu.git;a=commitdiff;h=e8d3b1a25f284cdf9705b7cf0412281cc9ee3a36

Does this problem occur in RHEL 7 ?

Version-Release number of selected component (if applicable):

$ rpm -qa | grep qemu
qemu-img-1.5.3-86.el7_1.5.x86_64
qemu-kvm-1.5.3-86.el7_1.5.x86_64
libvirt-daemon-driver-qemu-1.2.8-16.el7_1.3.x86_64
qemu-kvm-tools-1.5.3-86.el7_1.5.x86_64
ipxe-roms-qemu-20130517-6.gitc4bce43.el7.noarch
qemu-kvm-common-1.5.3-86.el7_1.5.x86_64

How reproducible:

Sorry, I have not tried. However, the reproduce procedure is explained in
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=e8d3b1a25f284cdf9705b7cf0412281cc9ee3a36

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Paolo Bonzini 2016-02-26 07:58:39 EST
Hi, the bug was introduced upstream by commit c2e50e3d11a0bf4c973cc30478c1af0f2d5f8e81 (thread-pool: avoid per-thread-pool EventNotifier).  Until that commit, the code in async.c is safe because bottom halves are never used across threads.  Thus:

- the qemu-kvm package, as well as the qemu-kvm-rhev-1.5.3 package is immune from the bug.

- the qemu-kvm-rhev-2.1.2 package has the bug

- the qemu-kvm-rhev-2.3.0 package has the above patch and the fix, and thus is also immune from the bug

Please close the bug if you are only interested in the 1.5.3 versions, or request the rhel-7.1.z flag if you are interested in a fix for qemu-kvm-rhev-2.1.2.
Comment 3 Yuki Shibuya 2016-02-28 21:09:57 EST
I appreciate your kind support.

We know the bug does not occur in qemu-kvm 1.5.3 versions by your answer.
We plan to use 1.5.3 versions, therefore I want to close this bug report as NOTABUG. 
Sorry, I couldn't find how to close bug. Can you please teach me how to close bug ?
Comment 4 Paolo Bonzini 2016-03-07 12:39:10 EST
Closing.  You might not have permissions to close bugs; here I see a dropdown control labelled "Status:" below the comment box.
Comment 5 Yuki Shibuya 2016-03-07 19:33:50 EST
(In reply to Paolo Bonzini from comment #4)
> Closing.  You might not have permissions to close bugs; here I see a
> dropdown control labelled "Status:" below the comment box.

Thank you.

Just as you say, I didn't probably have permission. I couldn't change a dropdown control labelled "Status:" at last time.
Comment 6 Paolo Bonzini 2016-07-18 10:47:54 EDT
*** Bug 1356849 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.