Bug 1310602 - HA | IPv6 | controllers looses their ipv6 ip address after reboot because of net.ipv6.conf.default.disable_ipv6=1. Should be 0.
HA | IPv6 | controllers looses their ipv6 ip address after reboot because of ...
Status: CLOSED DUPLICATE of bug 1309483
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: async
: 8.0 (Liberty)
Assigned To: Jiri Stransky
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 05:39 EST by Leonid Natapov
Modified: 2016-04-18 03:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 14:00:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2016-02-22 05:39:12 EST
Ccontrollers looses their ipv6 ip address after reboot/network restart because of net.ipv6.conf.default.disable_ipv6=1. Should be 0.

The value of net.ipv6.conf.default.disable_ipv6 in/etc/sysctl.conf file should be 0. 

/var/log/messages

Feb 21 15:18:57 overcloud-controller-2 systemd: Started Open vSwitch Internal Unit.
Feb 21 15:18:57 overcloud-controller-2 polkitd[1188]: Started polkitd version 0.112
Feb 21 15:18:58 overcloud-controller-2 dbus[1027]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
Feb 21 15:18:58 overcloud-controller-2 systemd: Started Authorization Manager.
Feb 21 15:18:58 overcloud-controller-2 dbus-daemon: dbus[1027]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
Feb 21 15:18:58 overcloud-controller-2 systemd: Started PCS GUI and remote configuration interface.
Feb 21 15:19:01 overcloud-controller-2 systemd: Started Initial cloud-init job (pre-networking).
Feb 21 15:19:03 overcloud-controller-2 NetworkManager[1079]: <info>  startup complete
Feb 21 15:19:03 overcloud-controller-2 systemd: Started Network Manager Wait Online.
Feb 21 15:19:03 overcloud-controller-2 systemd: Starting LSB: Bring up/down networking...
Feb 21 15:19:03 overcloud-controller-2 network: Bringing up loopback interface:  Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Feb 21 15:19:03 overcloud-controller-2 network: Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Feb 21 15:19:03 overcloud-controller-2 network: Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Feb 21 15:19:03 overcloud-controller-2 network: Could not load file '/etc/sysconfig/network-scripts/ifcfg-lo'
Feb 21 15:19:03 overcloud-controller-2 network: [  OK  ]
Feb 21 15:19:03 overcloud-controller-2 ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl -t 10 -- --may-exist add-br br-ex -- set bridge br-ex other-config:hwaddr=a0:36:9f:22:e6:f6
Feb 21 15:19:03 overcloud-controller-2 NetworkManager[1079]: <info>  (br-ex): link connected
Feb 21 15:19:04 overcloud-controller-2 network: Bringing up interface br-ex:  [  OK  ]
Feb 21 15:19:04 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_UP): em1: link is not ready
Feb 21 15:19:06 overcloud-controller-2 network: Bringing up interface em1:  [  OK  ]
Feb 21 15:19:07 overcloud-controller-2 kernel: ixgbe 0000:03:00.0: registered PHC device on em3
Feb 21 15:19:07 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_UP): em3: link is not ready
Feb 21 15:19:07 overcloud-controller-2 kernel: ixgbe 0000:03:00.0 em3: detected SFP+: 3
Feb 21 15:19:07 overcloud-controller-2 kernel: igb 0000:02:00.0 em1: igb: em1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
Feb 21 15:19:07 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): em1: link becomes ready
Feb 21 15:19:07 overcloud-controller-2 NetworkManager[1079]: <info>  (em1): link connected
Feb 21 15:19:07 overcloud-controller-2 kernel: ixgbe 0000:03:00.0 em3: NIC Link is Up 10 Gbps, Flow Control: RX/TX
Feb 21 15:19:07 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): em3: link becomes ready
Feb 21 15:19:07 overcloud-controller-2 NetworkManager[1079]: <info>  (em3): link connected
Feb 21 15:19:07 overcloud-controller-2 network: Bringing up interface em3:  [  OK  ]
Feb 21 15:19:07 overcloud-controller-2 kernel: ixgbe 0000:03:00.1: registered PHC device on em4
Feb 21 15:19:07 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_UP): em4: link is not ready
Feb 21 15:19:07 overcloud-controller-2 NetworkManager[1079]: <info>  (em4): enslaved to non-master-type device ovs-system; ignoring
Feb 21 15:19:07 overcloud-controller-2 kernel: ixgbe 0000:03:00.1 em4: detected SFP+: 4
Feb 21 15:19:08 overcloud-controller-2 kernel: ixgbe 0000:03:00.1 em4: NIC Link is Up 10 Gbps, Flow Control: RX/TX
Feb 21 15:19:08 overcloud-controller-2 kernel: IPv6: ADDRCONF(NETDEV_CHANGE): em4: link becomes ready
Feb 21 15:19:08 overcloud-controller-2 NetworkManager[1079]: <info>  (em4): enslaved to non-master-type device ovs-system; ignoring
Feb 21 15:19:08 overcloud-controller-2 NetworkManager[1079]: <info>  (em4): link connected
Feb 21 15:19:08 overcloud-controller-2 ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl -t 10 -- --if-exists del-port br-ex em4 -- add-port br-ex em4
Feb 21 15:19:08 overcloud-controller-2 network: Bringing up interface em4:  [  OK  ]
Feb 21 15:19:08 overcloud-controller-2 ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl -t 10 -- --may-exist add-port br-ex vlan184 tag=184 -- set Interface vlan184 type=internal
Feb 21 15:19:08 overcloud-controller-2 NetworkManager[1079]: <info>  (vlan184): link connected
Feb 21 15:19:08 overcloud-controller-2 network: Bringing up interface vlan184:  RTNETLINK answers: Permission denied
Feb 21 15:19:08 overcloud-controller-2 network: [  OK  ]
Feb 21 15:19:08 overcloud-controller-2 ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl -t 10 -- --may-exist add-port br-ex vlan188 tag=188 -- set Interface vlan188 type=internal
Feb 21 15:19:08 overcloud-controller-2 NetworkManager[1079]: <info>  (vlan188): link connected
Feb 21 15:19:09 overcloud-controller-2 network: Bringing up interface vlan188:  RTNETLINK answers: Permission denied
Feb 21 15:19:09 overcloud-controller-2 network: RTNETLINK answers: No route to host
Feb 21 15:19:09 overcloud-controller-2 network: [  OK  ]
Feb 21 15:19:09 overcloud-controller-2 systemd: Started LSB: Bring up/down networking.
Feb 21 15:19:09 overcloud-controller-2 systemd: Reached target Network.
Feb 21 15:19:09 overcloud-controller-2 systemd: Starting Network.
Feb 21 15:19:09 overcloud-controller-2 systemd: Starting Simple Network Management Protocol (SNMP) Daemon....
Feb 21 15:19:09 overcloud-controller-2 systemd: Starting DHCP interface br/int...
Feb 21 15:19:09 overcloud-controller-2 systemd: Starting DHCP interface em2...
Feb 21 15:19:09 overcloud-controller-2 systemd: Starting DHCP interface ovs/system...
Feb 21 15:19:09 overcloud-controller-2 systemd: Started DHCP interface lo.
Comment 2 Leonid Natapov 2016-02-22 14:00:24 EST

*** This bug has been marked as a duplicate of bug 1309483 ***

Note You need to log in before you can comment on or make changes to this bug.