Bug 1310794 - registration of OverCloud nodes to Satellite 6 broken
registration of OverCloud nodes to Satellite 6 broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 11:38 EST by David Juran
Modified: 2016-05-17 11:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-17 11:52:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2016-02-22 11:38:18 EST
Description of problem:
There are a number of problems with the latest version of /usr/share/openstack-tripleo-heat-templates/extraconfig/pre_deploy/rhel-registration/scripts/rhel-registration, breaking registration to Satellite 6

If REG_SAT_URL is passed as http://foo.bar the test in detect_satellite_version will mis-detect a Satellite 5 as the URL on line 101 will give a redirect.

If REG_SAT_URL on the other hand is passed as https://foo.bar, the download of katello-ca-consumer on line 122 will fail due to an invalid certificate.

Further, on line 120 there is a typo, "satellite_version" very rarely equals "6"...

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-121.el7ost
Comment 2 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 David Juran 2016-05-17 09:51:51 EDT
Actually, this bug _did_ make it into the OSP8 release...
Comment 5 Mike Burns 2016-05-17 11:52:00 EDT
Yes, yes it did.

Note You need to log in before you can comment on or make changes to this bug.