Bug 1310827 - Unable to register a rhel 6.8 client to SAM 1.4 on a rhel 6.8 server [NEEDINFO]
Unable to register a rhel 6.8 client to SAM 1.4 on a rhel 6.8 server
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
1.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: RHSM Documentation
Katello Bug Bin
:
: 1405515 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 12:44 EST by sthirugn@redhat.com
Modified: 2017-06-26 16:32 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: Consequence: Workaround (if any): Fix the system facts to have less than 255 characters Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:32:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
qianzhan: needinfo? (mmurray)
ktordeur: needinfo? (mmurray)
ktordeur: needinfo? (katello-bugs)
ktordeur: needinfo? (mmurray)


Attachments (Terms of Use)
Error log (47.87 KB, text/plain)
2016-02-22 12:51 EST, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2952001 None None None 2017-03-02 09:01 EST

  None (edit)
Description sthirugn@redhat.com 2016-02-22 12:44:51 EST
Description of problem:
Unable to register a rhel 6.8 client to SAM 1.4 on a rhel 6.8 server

Version-Release number of selected component (if applicable):
RHEL-6.8-20160222.n.0
SAM 1.4 (Version 1.4.3.28-1.el6sam_splice)
subscription-manager-1.16.8-2.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install SAM latest from CDN on a rhel 6.8 server (RHEL-6.8-20160222.n.0)
2. Register/Subscribe a rhel 6.8 client to the SAM server from Step 1:
   - Provision a rhel 6.8 client (RHEL-6.8-20160222.n.0)
   - Install SAM cert:
       rpm -Uvh http://$samhost/pub/candlepin-cert-consumer-latest.noarch.rpm
   - Register/Subsribe the new client to SAM server
     

Actual results:
On the client:
# rpm -Uvh http://$samhost/pub/candlepin-cert-consumer-latest.noarch.rpm
Retrieving http://$samhost/pub/candlepin-cert-consumer-latest.noarch.rpm
Preparing...                ########################################### [100%]
   1:candlepin-cert-consumer########################################### [100%]

# subscription-manager register --org ACME_Corporation --activationkey ak1
Problem creating unit Consumer [id = 8a90e0ef5309f79601530a0c349f0af5, type = ConsumerType [id=1000, label=system], getName() = $samhost]

# subscription-manager register --org=ACME_Corporation
Registering to: $samhost:443/sam/api
Username: admin
Password: 
Problem creating unit Consumer [id = 8a90e0ef5309f79601530a0d33aa0af9, type = ConsumerType [id=1000, label=system], getName() = $samhost]

# rpm -qa | grep subscription-manager
subscription-manager-1.16.8-2.el6.x86_64


Expected results:
Client is registered successfully

Additional info:
Comment 1 sthirugn@redhat.com 2016-02-22 12:51 EST
Created attachment 1129426 [details]
Error log
Comment 2 sthirugn@redhat.com 2016-02-22 12:52:45 EST
I copied the full log in the attachment.  The notable ones are:

==> /var/log/tomcat6/catalina.out <==
Feb 22, 2016 12:12:15 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 4219 ms
WARN [SqlExceptionHelper] - SQL Error: 0, SQLState: 22001 
ERROR [SqlExceptionHelper] - ERROR: value too long for type character varying(255) 
WARN [SqlExceptionHelper] - SQL Error: 0, SQLState: 22001 
ERROR [SqlExceptionHelper] - ERROR: value too long for type character varying(255) 
WARN [SqlExceptionHelper] - SQL Error: 0, SQLState: 22001 
ERROR [SqlExceptionHelper] - ERROR: value too long for type character varying(255) 
WARN [SqlExceptionHelper] - SQL Error: 0, SQLState: 22001 
ERROR [SqlExceptionHelper] - ERROR: value too long for type character varying(255) 

==> /var/log/messages <==
Feb 22 12:09:07 cloud-qe-4 yum[7288]: Installed: katello-glue-elasticsearch-1.4.3.28-1.el6sam_splice.noarch
Feb 22 12:09:32 cloud-qe-4 dbus: avc:  received policyload notice (seqno=5)
Feb 22 12:09:32 cloud-qe-4 dbus: [system] Reloaded configuration
Feb 22 12:09:33 cloud-qe-4 dbus: avc:  received policyload notice (seqno=6)
Feb 22 12:09:33 cloud-qe-4 dbus: [system] Reloaded configuration
Feb 22 12:09:33 cloud-qe-4 yum[7288]: Installed: katello-selinux-1.4.4-2.el6sat.noarch
Feb 22 12:09:34 cloud-qe-4 yum[7288]: Installed: katello-glue-candlepin-1.4.3.28-1.el6sam_splice.noarch
Feb 22 12:09:38 cloud-qe-4 yum[7288]: Installed: katello-headpin-1.4.3.28-1.el6sam_splice.noarch
Feb 22 12:09:38 cloud-qe-4 yum[7288]: Installed: ruby193-rubygem-katello-redhat-access-engine-0.0.1-1.el6sam.noarch
Feb 22 12:09:39 cloud-qe-4 yum[7288]: Installed: katello-headpin-all-1.4.3.28-1.el6sam_splice.noarch

==> /var/log/candlepin/candlepin.log <==
2016-02-22 12:46:18,846 [req=b75bae0a-a933-4621-89f9-d9c1e7024143, org=] INFO  org.candlepin.servlet.filter.logging.LoggingFilter - Request: verb=GET, uri=/candlepin/pools/8a90e0ef5309f79601530a09d5570a53
2016-02-22 12:46:18,893 [req=b75bae0a-a933-4621-89f9-d9c1e7024143, org=ACME_Corporation] INFO  org.candlepin.servlet.filter.logging.LoggingFilter - Response: status=200, content-type="application/json", time=47ms
2016-02-22 12:46:18,960 [req=630c1246-0c9d-4eca-9ad5-3da5e416a491, org=] INFO  org.candlepin.servlet.filter.logging.LoggingFilter - Request: verb=POST, uri=/candlepin/environments/1/consumers/
2016-02-22 12:46:19,001 [req=630c1246-0c9d-4eca-9ad5-3da5e416a491, org=] ERROR org.candlepin.resource.ConsumerResource - Problem creating unit:
javax.persistence.PersistenceException: org.hibernate.exception.DataException: could not execute statement
	at org.hibernate.ejb.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1387) ~[hibernate-entitymanager-4.2.5.Final-redhat-1.jar:4.2.5.Final-redhat-1]
	at org.hibernate.ejb.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1310) ~[hibernate-entitymanager-4.2.5.Final-redhat-1.jar:4.2.5.Final-redhat-1]
	at org.hibernate.ejb.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1316) ~[hibernate-entitymanager-4.2.5.Final-redhat-1.jar:4.2.5.Final-redhat-1]
	at org.hibernate.ejb.AbstractEntityManagerImpl.flush(AbstractEntityManagerImpl.java:999) ~[hibernate-entitymanager-4.2.5.Final-redhat-1.jar:4.2.5.Final-redhat-1]
	at org.candlepin.model.AbstractHibernateCurator.flush(AbstractHibernateCurator.java:363) ~[AbstractHibernateCurator.class:na]
	at org.candlepin.model.AbstractHibernateCurator.save(AbstractHibernateCurator.java:358) ~[AbstractHibernateCurator.class:na]
	at org.candlepin.model.AbstractHibernateCurator.create(AbstractHibernateCurator.java:111) ~[AbstractHibernateCurator.class:na]
	at org.candlepin.model.ConsumerCurator.create(ConsumerCurator.java:74) ~[ConsumerCurator.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:58) ~[guice-persist-3.0-redhat-1.jar:3.0-redhat-1]
	at org.candlepin.resource.ConsumerResource.create(ConsumerResource.java:458) ~[ConsumerResource.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:66) ~[guice-persist-3.0-redhat-1.jar:3.0-redhat-1]
	at org.candlepin.resource.EnvironmentResource.create(EnvironmentResource.java:265) [EnvironmentResource.class:na]
	at sun.reflect.GeneratedMethodAccessor281.invoke(Unknown Source) ~[na:na]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_71]
	at java.lang.reflect.Method.invoke(Method.java:497) ~[na:1.8.0_71]
	at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:155) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:257) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:222) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:211) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:525) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:502) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:119) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50) [resteasy-jaxrs-2.3.2.Final-redhat-1.jar:2.3.2.Final-redhat-1]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:723) [tomcat6-servlet-2.5-api-6.0.24.jar:na]
	at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:263) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:178) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:62) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at org.candlepin.servlet.filter.ContentTypeHackFilter.doFilter(ContentTypeHackFilter.java:58) [ContentTypeHackFilter.class:na]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0-redhat-1.jar:3.0-redhat-1]
	at org.candlepin.servlet.filter.logging.LoggingFilter.doFilter(LoggingFilter.java:77) [LoggingFilter.cl
Comment 3 sthirugn@redhat.com 2016-02-22 14:03:06 EST
Barnaby Court (from Candlepin) noted in irc that this is happening due to fact length > 255 and is a known issue with old versions of candlepin.  In my scenario, proc_cpuinfo.common.flags was 356 characters. 

As a workaround (suggested by Barnaby) I created a rhsm fact override file with the fact length less than 255 characters and registered again and it worked good.

# echo '{"proc_cpuinfo.common.flags":"*****************"}' > /etc/rhsm/facts/cpuinfo_override.facts

# subscription-manager register --org=ACME_Corporation --activationkey=ak1
The system has been registered with ID: 8ad47be7-18eb-4d7f-99b2-3831ac1abc79 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed
Comment 5 qianzhan 2016-03-02 04:31:39 EST
When testing RHEL-6.8-server-ppc64-20160225.0, I still met this issue with facts changed:

[root@ibm-p8-kvm-04-guest-05 ~]# cat /etc/rhsm/facts/cpuinfo_override.facts 
{"proc_cpuinfo.common.flags":"*****************"}

[root@ibm-p8-kvm-04-guest-05 ~]# subscription-manager register
Registering to: samserv.redhat.com:443/sam/api
Username: admin
Password: 
Problem creating unit Consumer [id = 8ac20118521ac3820153369db9a913a1, type = ConsumerType [id=1000, label=system], getName() = ibm-p8-kvm-04-guest-05.rhts.eng.bos.redhat.com]
Comment 6 Dennixx 2016-06-22 09:14:51 EDT
As I understand (from bug 1165193) this issue was fixed in the Subscription Manager server back in september last year. How about releasing an erratum which fixes this in the SAM server?
Comment 7 ajanorka 2016-07-08 05:28:50 EDT
Hello,

One of Customers is facing the same problem while registering the system on SAM1.4

I checked the fact list count which is not more than 255. Still the issue persists :-
============
# subscription-manager facts --list | wc -l
148

network.ipv6_address is already set to ::1
=============

Please let us know if we have any workaround.

Regards,
Anuja
Comment 8 Dennixx 2016-07-08 06:31:04 EDT
(In reply to ajanorka from comment #7)

> One of Customers is facing the same problem while registering the system on
> SAM1.4
> 
> I checked the fact list count which is not more than 255. Still the issue
> persists :-
> ============
> # subscription-manager facts --list | wc -l
> 148
> 
> network.ipv6_address is already set to ::1
> =============
> 
> Please let us know if we have any workaround.

It's not the *number* of facts, but the *length* of the facts which should not exceed 255.
My guess is that it's the 'proc_cpuinfo.common.flags' fact which is too long.
Comment 10 ajanorka 2016-07-12 07:23:55 EDT
(In reply to qianzhan from comment #5)
> When testing RHEL-6.8-server-ppc64-20160225.0, I still met this issue with
> facts changed:
> 
> [root@ibm-p8-kvm-04-guest-05 ~]# cat /etc/rhsm/facts/cpuinfo_override.facts 
> {"proc_cpuinfo.common.flags":"*****************"}
> 
> [root@ibm-p8-kvm-04-guest-05 ~]# subscription-manager register
> Registering to: samserv.redhat.com:443/sam/api
> Username: admin
> Password: 
> Problem creating unit Consumer [id = 8ac20118521ac3820153369db9a913a1, type
> = ConsumerType [id=1000, label=system], getName() =
> ibm-p8-kvm-04-guest-05.rhts.eng.bos.redhat.com]

qianzhan,

Even the workaround did not help for my customer.
Do we have any other workaround for this ?

Regards,
Anuja
Comment 11 qianzhan 2016-07-12 23:15:16 EDT
(In reply to ajanorka from comment #10)
> (In reply to qianzhan from comment #5)
> > When testing RHEL-6.8-server-ppc64-20160225.0, I still met this issue with
> > facts changed:
> > 
> > [root@ibm-p8-kvm-04-guest-05 ~]# cat /etc/rhsm/facts/cpuinfo_override.facts 
> > {"proc_cpuinfo.common.flags":"*****************"}
> > 
> > [root@ibm-p8-kvm-04-guest-05 ~]# subscription-manager register
> > Registering to: samserv.redhat.com:443/sam/api
> > Username: admin
> > Password: 
> > Problem creating unit Consumer [id = 8ac20118521ac3820153369db9a913a1, type
> > = ConsumerType [id=1000, label=system], getName() =
> > ibm-p8-kvm-04-guest-05.rhts.eng.bos.redhat.com]
> 
> qianzhan,
> 
> Even the workaround did not help for my customer.
> Do we have any other workaround for this ?
> 
> Regards,
> Anuja

Hey Anuja,

I added comment 5 when I tested integration test with SAM and RHEL-6.8-server-ppc64-20160225.0. And I did not meet this issue when I tested again about 1 week later. As per comment 3, I suggest you to check if any other facts' value length exceeds 255 characters.

For example:

1) I installed a new rhel6.8, and register to SAM.
[root@dhcp-128-89 ~]# subscription-manager register
Registering to: ent-02-vm-03.lab.eng.nay.redhat.com:443/sam/api
Username: admin
Password: 
The system has been registered with ID: 1686eb0c-4c4b-4a84-9620-f0ec32bcb722 

2) Then I checked the facts of rhel6.8, and find fact 'proc_cpuinfo.common.flags' has the longest fact value(151 characters < 255 characters).

[root@dhcp-128-89 ~]# subscription-manager facts 
cpu.core(s)_per_socket: 1
cpu.cpu(s): 1
cpu.cpu_socket(s): 1
cpu.thread(s)_per_core: 1
cpu.topology_source: kernel /sys cpu sibling lists
distribution.id: Santiago
distribution.name: Red Hat Enterprise Linux Server
distribution.version: 6.8
dmi.bios.address: 0xe8000
dmi.bios.bios_revision: 1.0
dmi.bios.relase_date: 01/01/2007
dmi.bios.rom_size: 64 KB
dmi.bios.runtime_size: 96 KB
dmi.bios.vendor: Seabios
dmi.bios.version: 0.5.1
dmi.chassis.asset_tag: Not Specified
dmi.chassis.boot-up_state: Safe
dmi.chassis.lock: Not Present
dmi.chassis.manufacturer: Red Hat
dmi.chassis.power_supply_state: Safe
dmi.chassis.security_status: Unknown
dmi.chassis.serial_number: Not Specified
dmi.chassis.thermal_state: Safe
dmi.chassis.type: Other
dmi.chassis.version: Not Specified
dmi.memory.array_handle: 0x1000
dmi.memory.bank_locator: Not Specified
dmi.memory.data_width: 64 bit
dmi.memory.error_correction_type: Multi-bit ECC
dmi.memory.error_information_handle: Not Provided
dmi.memory.form_factor: DIMM
dmi.memory.location: Other
dmi.memory.locator: DIMM 0
dmi.memory.maximum_capacity: 1 GB
dmi.memory.size: 1024 MB
dmi.memory.speed:   (ns)
dmi.memory.total_width: 64 bit
dmi.memory.type: RAM
dmi.memory.use: System Memory
dmi.processor.family: Other
dmi.processor.socket_designation: CPU 1
dmi.processor.status: Populated:Enabled
dmi.processor.type: Central Processor
dmi.processor.upgrade: Other
dmi.processor.version: Not Specified
dmi.processor.voltage: Unknown
dmi.system.family: Red Hat Enterprise Linux
dmi.system.manufacturer: Red Hat
dmi.system.product_name: KVM
dmi.system.serial_number: Not Specified
dmi.system.sku_number: Not Specified
dmi.system.status: No errors detected
dmi.system.uuid: a53c3033-5b52-c132-c260-8756559b06cc
dmi.system.version: RHEL 6.6.0 PC
dmi.system.wake-up_type: Power Switch
lscpu.architecture: x86_64
lscpu.bogomips: 6784.60
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 1
lscpu.cpu_family: 6
lscpu.cpu_mhz: 3392.302
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.hypervisor_vendor: KVM
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 4096K
lscpu.model: 13
lscpu.model_name: QEMU Virtual CPU version (cpu64-rhel6)
lscpu.numa_node(s): 1
lscpu.numa_node0_cpu(s): 0
lscpu.on-line_cpu(s)_list: 0
lscpu.socket(s): 1
lscpu.stepping: 3
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: GenuineIntel
lscpu.virtualization_type: full
memory.memtotal: 1020120
memory.swaptotal: 1023996
net.interface.eth1.ipv4_address: 10.66.128.214
net.interface.eth1.ipv4_broadcast: 10.66.129.255
net.interface.eth1.ipv4_netmask: 23
net.interface.eth1.ipv6_address.link: fe80::5054:ff:fe90:8ba8
net.interface.eth1.ipv6_netmask.link: 64
net.interface.eth1.mac_address: 52:54:00:90:8B:A8
net.interface.lo.ipv4_address: 127.0.0.1
net.interface.lo.ipv4_broadcast: Unknown
net.interface.lo.ipv4_netmask: 8
net.interface.lo.ipv6_address.host: ::1
net.interface.lo.ipv6_netmask.host: 128
network.hostname: dhcp-128-89.nay.redhat.com
network.ipv4_address: 127.0.0.1
network.ipv6_address: ::1
proc_cpuinfo.common.address_sizes: 36 bits physical, 48 bits virtual
proc_cpuinfo.common.apicid: 0
proc_cpuinfo.common.bogomips: 6784.60
proc_cpuinfo.common.cache_alignment: 64
proc_cpuinfo.common.cache_size: 4096 KB
proc_cpuinfo.common.clflush_size: 64
proc_cpuinfo.common.core_id: 0
proc_cpuinfo.common.cpu_cores: 1
proc_cpuinfo.common.cpu_family: 6
proc_cpuinfo.common.cpu_mhz: 3392.302
proc_cpuinfo.common.cpuid_level: 4
proc_cpuinfo.common.flags: fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm
proc_cpuinfo.common.fpu: yes
proc_cpuinfo.common.fpu_exception: yes
proc_cpuinfo.common.initial_apicid: 0
proc_cpuinfo.common.microcode: 1
proc_cpuinfo.common.model: 13
proc_cpuinfo.common.model_name: QEMU Virtual CPU version (cpu64-rhel6)
proc_cpuinfo.common.physical_id: 0
proc_cpuinfo.common.power_management: Unknown
proc_cpuinfo.common.processor: 0
proc_cpuinfo.common.siblings: 1
proc_cpuinfo.common.stepping: 3
proc_cpuinfo.common.vendor_id: GenuineIntel
proc_cpuinfo.common.wp: yes
system.certificate_version: 3.2
uname.machine: x86_64
uname.nodename: dhcp-128-89.nay.redhat.com
uname.release: 2.6.32-642.el6.x86_64
uname.sysname: Linux
uname.version: #1 SMP Wed Apr 13 00:51:26 EDT 2016
virt.host_type: kvm
virt.is_guest: True
virt.uuid: a53c3033-5b52-c132-c260-8756559b06cc

3) I doubled the length of 'proc_cpuinfo.common.flags' fact, and tried to register. The registration failed!

[root@dhcp-128-89 ~]# cat /etc/rhsm/facts/cpuinfo_override.facts
{"proc_cpuinfo.common.flags":" fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm"}

[root@dhcp-128-89 ~]# subscription-manager register
Registering to: ent-02-vm-03.lab.eng.nay.redhat.com:443/sam/api
Username: admin
Password: 
Problem creating unit Consumer [id = 8ac213ad55dee36d0155e22470910d55, type = ConsumerType [id=1000, label=system], getName() = dhcp-128-89.nay.redhat.com]

4) So I recover the value of "proc_cpuinfo.common.flags" to 151, and change the value of 'dmi.memory.error_information_handle' to 302 character. Then I register again.

[root@dhcp-128-89 ~]#  cat /etc/rhsm/facts/cpuinfo_override.facts
{"proc_cpuinfo.common.flags":" fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm"}


[root@dhcp-128-89 ~]# cat /etc/rhsm/facts/dmi_override.facts
{"dmi.memory.error_information_handle":" fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm fpu de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pse36 clflush mmx fxsr sse sse2 syscall nx lm up unfair_spinlock pni cx16 hypervisor lahf_lm"}

[root@dhcp-128-89 ~]# subscription-manager register
Registering to: ent-02-vm-03.lab.eng.nay.redhat.com:443/sam/api
Username: admin
Password: 
Problem creating unit Consumer [id = 8ac213ad55dee36d0155e228bdc20d5e, type = ConsumerType [id=1000, label=system], getName() = dhcp-128-89.nay.redhat.com]



Hope above all can help you. Please make sure all lengths of the facts value do NOT exceed 255 characters, and try to register.
Comment 12 ajanorka 2016-08-03 07:17:05 EDT
Hello Qianqian,

Superb! Let me try implementing this in customer's system. This will work for sure I believe.

Thanks much!

Regards,
Anuja
Comment 15 Brian Klauss 2016-08-24 16:07:45 EDT
This bug still exists with RHEL 6.8 and latest version of SAM.  Even with the "hack" listed above, it does not resolve the problem.  I'm attaching the /var/log/rhsm/rhsm.log:

2016-08-24 14:05:53,631 [DEBUG] subscription-manager:10363 @ga_loader.py:89 - ga_loader GaImporterGtk2
2016-08-24 14:05:53,636 [DEBUG] subscription-manager:10363 @plugins.py:569 - loaded plugin modules: []
2016-08-24 14:05:53,636 [DEBUG] subscription-manager:10363 @plugins.py:570 - loaded plugins: {}
2016-08-24 14:05:53,637 [DEBUG] subscription-manager:10363 @identity.py:131 - Loading consumer info from identity certificates.
2016-08-24 14:05:53,637 [DEBUG] subscription-manager:10363 @identity.py:146 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2016-08-24 14:05:53,692 [INFO] subscription-manager:10363 @managercli.py:367 - Client Versions: {'python-rhsm': '1.16.6-1.el6', 'subscription-manager': '1.16.8-8.el6'}
2016-08-24 14:05:53,693 [INFO] subscription-manager:10363 @connection.py:815 - Connection built: host=dpv-rhsam1.us.signintra.com port=443 handler=/sam/api auth=identity_cert ca_dir=/etc/rhsm/ca/ verify=False
2016-08-24 14:05:53,693 [INFO] subscription-manager:10363 @connection.py:815 - Connection built: host=dpv-rhsam1.us.signintra.com port=443 handler=/sam/api auth=none
2016-08-24 14:05:53,694 [INFO] subscription-manager:10363 @managercli.py:367 - Client Versions: {'python-rhsm': '1.16.6-1.el6', 'subscription-manager': '1.16.8-8.el6'}
2016-08-24 14:05:53,713 [INFO] subscription-manager:10363 @managercli.py:342 - Consumer Identity name=None uuid=None
2016-08-24 14:05:53,722 [INFO] subscription-manager:10363 @managercli.py:342 - Consumer Identity name=None uuid=None
2016-08-24 14:05:57,860 [INFO] subscription-manager:10363 @connection.py:815 - Connection built: host=dpv-rhsam1.us.signintra.com port=443 handler=/sam/api auth=basic username=admin
2016-08-24 14:05:57,879 [DEBUG] subscription-manager:10363 @hwprobe.py:580 - cpu info: {'cpu.cpu(s)': 2, 'cpu.core(s)_per_socket': 1, 'cpu.thread(s)_per_core': 1, 'cpu.topology_source': 'kernel /sys cpu sibling lists', 'cpu.cpu_socket(s)': 2}
2016-08-24 14:05:57,887 [DEBUG] subscription-manager:10363 @hwprobe.py:798 - Running 'virt-what'
2016-08-24 14:05:58,029 [DEBUG] subscription-manager:10363 @hwprobe.py:802 - virt-what stdout: vmware

2016-08-24 14:05:58,030 [DEBUG] subscription-manager:10363 @hwprobe.py:803 - virt-what stderr: 
2016-08-24 14:05:58,177 [INFO] subscription-manager:10363 @hwprobe.py:908 - collected virt facts: virt.is_guest=True, virt.host_type=vmware, virt.uuid=42132598-1b8a-8889-51d4-25ddd7b6e23f
2016-08-24 14:05:58,178 [INFO] subscription-manager:10363 @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/migration.facts
2016-08-24 14:05:58,179 [DEBUG] subscription-manager:10363 @connection.py:509 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, candlepin-local.pem
2016-08-24 14:05:58,180 [DEBUG] subscription-manager:10363 @connection.py:557 - Making request: GET /sam/api/users/admin/owners
2016-08-24 14:05:58,210 [DEBUG] subscription-manager:10363 @connection.py:589 - Response: status=200
2016-08-24 14:05:58,212 [DEBUG] subscription-manager:10363 @connection.py:509 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, candlepin-local.pem
2016-08-24 14:05:58,212 [DEBUG] subscription-manager:10363 @connection.py:557 - Making request: GET /sam/api/
2016-08-24 14:05:58,258 [DEBUG] subscription-manager:10363 @connection.py:589 - Response: status=200
2016-08-24 14:05:58,259 [DEBUG] subscription-manager:10363 @connection.py:832 - Server supports the following resources: {'status': '/api/status/', 'organizations': '/api/organizations/', 'roles': '/api/roles/', 'sync_plans': '/api/sync_plans/', 'users': '/api/users/', 'distributors': '/api/distributors/', 'providers': '/api/providers/', 'entitlements': '/api/entitlements/', 'content_overrides': '/api/content_overrides', 'content_views': '/api/content_views/', 'guestids': '/api/guestids', 'system_groups': '/api/system_groups/', 'products': '/api/products/', 'systems': '/api/systems/', 'activation_keys': '/api/activation_keys/', 'content_view_definitions': '/api/content_view_definitions/', 'consumers': '/api/consumers/'}
2016-08-24 14:05:58,261 [DEBUG] subscription-manager:10363 @connection.py:509 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, candlepin-local.pem
2016-08-24 14:05:58,261 [DEBUG] subscription-manager:10363 @connection.py:557 - Making request: POST /sam/api/consumers?owner=Schenker_DDC
2016-08-24 14:05:58,637 [DEBUG] subscription-manager:10363 @connection.py:589 - Response: status=400
2016-08-24 14:05:58,638 [ERROR] subscription-manager:10363 @managercli.py:1108 - Problem creating unit Consumer [id = 8a5c83fb56bdbce60156be28c613014d, type = ConsumerType [id=1000, label=system], getName() = ddv-aeroweb1.us.signintra.com]
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1103, in _do_command
    content_tags=self.installed_mgr.tags)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 913, in registerConsumer
    return self.conn.request_post(url, params)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 684, in request_post
    return self._request("POST", method, params)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 598, in _request
    self.validateResponse(result, request_type, handler)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 648, in validateResponse
    raise RestlibException(response['status'], error_msg, response.get('headers'))
RestlibException: Problem creating unit Consumer [id = 8a5c83fb56bdbce60156be28c613014d, type = ConsumerType [id=1000, label=system], getName() = ddv-aeroweb1.us.signintra.com]

This needs to be resolved ASAP.

Thank you,
Brian Klauss
Comment 18 Kenny Tordeurs 2016-12-19 04:56:21 EST
*** Bug 1405515 has been marked as a duplicate of this bug. ***
Comment 22 Bryan Kearney 2017-06-26 16:32:37 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.