This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1310875 - KDE Plasma crashes when the mouse pointer repeatedly hovers the TaskManager
KDE Plasma crashes when the mouse pointer repeatedly hovers the TaskManager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plasma-workspace (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-22 16:06 EST by Giulio 'juliuxpigface'
Modified: 2016-02-22 18:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 18:35:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 357895 None None None 2016-02-22 16:06 EST

  None (edit)
Description Giulio 'juliuxpigface' 2016-02-22 16:06:11 EST
Description of problem:
It's trivial to trigger a crash on Fedora 24 2016022 Rawhide KDE.
There is an upstream bug: https://bugs.kde.org/show_bug.cgi?id=357895.
It seems that a commit already fixed it: https://bugs.kde.org/show_bug.cgi?id=357895#c45

Since it's a nasty issue, I thought it would have been a good idea to file this downstream ticket in order to keep track of it. Please forgive me if I'm wrong.

The component is just a guess, I'm not so familiar with the KDE Ecosystem.

Version-Release number of selected component (if applicable):
plasma-workspace-5.5.4-3.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log In to Plasma
2. Hover repeatedly the task manager with the mouse

Actual results:
1. The entire Plasma's workspace crashes

Expected results:
1. Plasma's workspace should not crash.
Comment 1 Rex Dieter 2016-02-22 18:35:31 EST
backported upstream commit

%changelog
* Mon Feb 22 2016 Rex Dieter <rdieter@fedoraproject.org> 5.19.0-3
- KDE Plasma crashes when the mouse pointer repeatedly hovers the TaskManager (#1310875)
Comment 2 Rex Dieter 2016-02-22 18:35:57 EST
To be clear, fix landed in kf5-plasma-5.19.0-3

Note You need to log in before you can comment on or make changes to this bug.