Bug 13110 - SegFault in rpm ...
SegFault in rpm ...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-27 10:40 EDT by lonoak
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-26 20:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lonoak 2000-06-27 10:40:09 EDT
Ok, first I'll explain the 'history' behind this bug:

  - First I installed gimp-perl-1.1.22-1.rpm (rpm -i <package>)
  - Then I installed the gimp and gimp-devel for gnome-helix, version 1.22
  - Then, compiled by hand gimp-perl 1.2, without uninstalling the 
 previous rpm. 

 gimp-perl works fine, but now I'm trying to do an upgrade, and rpm says
that gimp-1.22 depends on gimp-perl-1.22, and it can be deleted ... here's
the complete log:

[root@pcbeca4 /tmp]# rpm -qa |grep gimp
gimp-devel-1.1.22-0_helix_1
gimp-perl-1.1.22-1
gimp-1.1.22-0_helix_1
gimp-data-extras-1.0.0-4
[root@pcbeca4 /tmp]# rpm -e gimp-devel-1.1.22-0_helix_1
[root@pcbeca4 /tmp]# rpm -e gimp-1.1.22-0_helix_1
error: removing these packages would break dependencies:
        gimp is needed by gimp-perl-1.1.22-1
        libgimp-1.1.so.22 is needed by gimp-perl-1.1.22-1
        libgimpui-1.1.so.22 is needed by gimp-perl-1.1.22-1
[root@pcbeca4 /tmp]# rpm -e gimp
error: removing these packages would break dependencies:
        gimp is needed by gimp-perl-1.1.22-1
        libgimp-1.1.so.22 is needed by gimp-perl-1.1.22-1
        libgimpui-1.1.so.22 is needed by gimp-perl-1.1.22-1
[root@pcbeca4 /tmp]# rpm -e gimp-perl
Segmentation fault
[root@pcbeca4 /tmp]# rpm -vv -e gimp-perl
D: opening database mode 0x82 in /var/lib/rpm
D: getting list of mounted filesystems
Segmentation fault
[root@pcbeca4 /tmp]# rpm -i --force /tmp/gimp-perl-1.1.22-1.i386.rpm
Segmentation fault
[root@pcbeca4 /tmp]# rpm -vv -i --force /tmp/gimp-perl-1.1.22-1.i386.rpm
D: counting packages to install
D: found 1 packages
D: looking for packages to download
D: retrieved 0 packages
D: New Header signature
D: Signature size: 68
D: Signature pad : 4
D: sigsize         : 72
D: Header + Archive: 205661
D: expected size   : 205661
D: opening database mode 0x42 in /var/lib/rpm
D: found 0 source and 1 binary packages
D:  requires: gimp  satisfied by db packages.
D:  requires: perl  satisfied by db provides.
D:  requires: ld-linux.so.2  satisfied by db provides.
D:  requires: libc.so.6  satisfied by db provides.
D:  requires: libgimp-1.1.so.22  satisfied by db provides.
D:  requires: libgimpui-1.1.so.22  satisfied by db provides.
D:  requires: libglib-1.2.so.0  satisfied by db provides.
D:  requires: /usr/bin/perl  satisfied by db file lists.
D:  requires: libc.so.6(GLIBC_2.0)  satisfied by db provides.
D: installing binary packages
D: getting list of mounted filesystems
Segmentation fault
[root@pcbeca4 /tmp]#

----
problems with mounted filesystems ? I think there's no problem ...

;-?

what to do ?

Thanks.
Comment 1 Jeff Johnson 2000-07-20 13:58:00 EDT
Try
	rpm --rebuilddb
because rpm relies on consistent data from the database, and all sorts of
weirdness ensues if the data is inconsistent. I believe that will fix your
problem.

Otherwise, please reopen this bug.

Comment 2 lonoak 2000-07-21 04:48:40 EDT
+
  +------- Additional comments from jbj@redhat.com 2000-07-20 13:58 -------
  +Try
  + rpm --rebuilddb
  +because rpm relies on consistent data from the database, and all sorts of
  +weirdness ensues if the data is inconsistent. I believe that will fix your
  +problem.
  +
  +Otherwise, please reopen this bug.
  +

 The problem still continues ... here's the log of what i have done ...

[root@pcbeca4 macias]# rpm --rebuilddb
[root@pcbeca4 macias]# rpm -e gimp-perl
Segmentation fault
[root@pcbeca4 macias]# 

I can't remember if I installed the package before doing a  partition moving ...
a few months ago I had the /usr directory mounted as one partition in the
primary hard drive, then I changed the contents of /usr to a new disc, using the
tar command: 'tar --preserve -clf - . | (cd /mnt ; tar --preserve -xf- ) '. But
I have this problem only with this package, and it's necessary to me for
updating my gimp package.

I still could not remove tha package, so i'll appreciate your help.
  
Thanks again,
 
jose.
Comment 3 Jeff Johnson 2000-07-26 20:01:16 EDT
The next level is to try removing with --ignoresize, as that will skip diskspace
checks
(that's the last thing on your screen).

After that (or at the same time), try adding -vv, and appending the output here.
I may be able
to tell something more from that.
Comment 4 Jeff Johnson 2000-07-31 11:40:36 EDT
This is a problem with the gimp-perl entry in your database. Send me
(jbj@redhat.com) a copy
of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm
and I'll take a look. Meanwhile, I'm gonna close this bug, since I cannot
re[produce the problem.

Note You need to log in before you can comment on or make changes to this bug.