Bug 1311067 - [User Portal] 'Error while executing action VmLogon: Internal Engine Error' when opening console
[User Portal] 'Error while executing action VmLogon: Internal Engine Error' w...
Status: CLOSED DUPLICATE of bug 1305819
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.3.2
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 05:17 EST by Jiri Belka
Modified: 2016-03-14 03:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 03:01:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑4.1?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2016-02-23 05:17:43 EST
Description of problem:

When an user tries to open console of a VM in User Portal which was stopped but User Portal has not refresh the VM status yet, the user sees in User Portal:

Operation Cancelled
'Error while executing action VmLogon: Internal Engine Error'

Version-Release number of selected component (if applicable):
rhevm-userportal-3.6.3.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. have an user and open a VM console in User Portal
2. login with another user which has rights to open same VM console
3. for the latter user change refresh time in User Portal to 60 secs
   (to ease refresh delay)
4. as the former user shutdown the VM
5. when the VM is down, as latter user (with "slow" refresh) observe the VM icon
   and it is allows to open console (thus VM status has not been refreshed yet),
   double click on the VM icon to open console
6. observe User Portal for popup window

Actual results:
Operation Cancelled
'Error while executing action VmLogon: Internal Engine Error'

Expected results:
human readable error msg

Additional info:
Comment 2 Tomas Jelinek 2016-02-24 02:44:24 EST
Seems to be related to https://bugzilla.redhat.com/show_bug.cgi?id=1305819 - other incarnation of engine exception when doing an action on a VM which is down.
Comment 3 Michal Skrivanek 2016-03-14 03:01:50 EDT
let's track it only once

*** This bug has been marked as a duplicate of bug 1305819 ***

Note You need to log in before you can comment on or make changes to this bug.