Bug 1311117 - disk size error, after snapshot preallocated disk
disk size error, after snapshot preallocated disk
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.2.6
x86_64 Linux
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Ala Hino
Aharon Canan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 07:31 EST by boruvka.michal
Modified: 2016-03-10 07:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:48:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53883 None None None 2016-02-28 07:14 EST

  None (edit)
Description boruvka.michal 2016-02-23 07:31:21 EST
Description of problem:

1. I have VM with preallocated disk 20G.
2. Now I create snapshot. (in VM I see 20GB disk)
3. Now I Copy some data (5GB) to VM. 
4. Delete snapshot. 
5. Now Actual disk size is 24G and virtual size is 20G
6. stop/start VM
7. In VM I see 24GB disk, but I should si 20GB disk !!!

Version-Release number of selected component (if applicable):
ovirt-engine 3.6.2.6
vdsm 4.17.18-1.el7

How reproducible:
always

Steps to Reproduce:
1. viz. Description

Actual results:


Expected results:


Additional info:
Comment 1 Allon Mureinik 2016-02-23 07:40:00 EST
Ala/Adam, this looks like the same issue as bug 1301709. Please either confirm (and reset the target milestone to 3.6.3 and move the bug to MODIFIED) or issue a fix for 3.6.5.
Comment 2 Allon Mureinik 2016-02-28 08:17:29 EST
(In reply to Allon Mureinik from comment #1)
> Ala/Adam, this looks like the same issue as bug 1301709. Please either
> confirm (and reset the target milestone to 3.6.3 and move the bug to
> MODIFIED) or issue a fix for 3.6.5.
Moving to ON_QA.
QA - up to you to either verify this scenario with vdsm-4.17.23 or newer (as per the fix for bug 1301709), or close as a duplicate.
Comment 3 Raz Tamir 2016-03-01 10:04:03 EST
Verified using the steps in bug 1301709:
1. Create VM (preallocated disk over ISCSI SD)
2. Create 2 snapshots
3. Live merge one of the snapshots
4. Clone a VM from the snapshot left

rhevm-3.6.3.4-0.1.el6.noarch
vdsm-4.17.23-0.el7ev.noarch

Note You need to log in before you can comment on or make changes to this bug.