Bug 1311162 - Address feedback on Chapter 3
Address feedback on Chapter 3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Allison Heslin
Brandi
:
: 1315026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 09:29 EST by Allison Heslin
Modified: 2016-04-27 19:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 19:58:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allison Heslin 2016-02-23 09:29:32 EST
Section 3.1.1 - Step 2 looks wonky

Section 3.1.2 - Steps look wonky too. Also, the external resources seem to be a bit out of installation, and into initial configuration.

Section 3 Installing Satellite Server- This section describes both the connected and disconnected methods of installing Satellite, but then lists only the tasks for a connected installation.

3.1.1. Downloading and Installing from a Connected Network
Aren’t some of these commands duplicates of those in 2.5?

3.1.2. Downloading and Installing from a Disconnected Network
The disclaimers in this section make the disconnected option appear a substandard option, but it is not.

Response from Rich Jerrido - What we try to avoid is users installing old bits from ISO because of the 'sat5 way', where you could only install the product via ISO. We don't refresh the ISOs with every z-stream, so unless you absolutely have to, don't use them.

The following is stated as a prerequisite, but instructions for this task then appear in this section’s first procedure. “Ensure the latest Binary DVD images for both Satellite Server and the host (the base system) are present on, or accessible from, the base system.” 

3.1.1 Downloading and Installing Satellite Server
Step 2: Change code block to # subscription-manager subscribe --pool= \
(Remove additional code)

Step 3: Change to # subscription-manager repos --disable ‘’*’’

Step 4: Change choice table to code blocks (universal change with RHEL 6 and 7 choices)
Change to --enable rhel-server-rhscl-6-rpms (missing the 6)

3.1.2.2: Configuring the Base System with Offline Repositories
Step 6 change ISO version for Satellite (to 6.2)

* Chapter 3 - Installing Satellite Server.

"You can obtain the packages necessary to install Satellite Server by either downloading them
directly from the Red Hat Content Delivery Network (CDN), by downloading an ISO image of the
packages from an external computer.
For hosts that have network connectivity, Red Hat recommends downloading the packages directly
from the CDN. Using ISO images is only recommended for hosts in a disconnected environment
because ISO images may not contain the latest updates."

suggested improvement

"You can obtain the packages necessary to install Satellite Server by either installing them
directly from the Red Hat Content Delivery Network (CDN) or by downloading an ISO image of the
packages from an external computer and copying it to the Satellite for installation.
For hosts that have network connectivity, Red Hat recommends installing the packages directly
from the CDN. Using ISO images is only recommended for hosts in a disconnected environment
because ISO images may not contain the latest updates."

* Section 3.11

step 2: subscription-manager subscribe is deprecated. Use subscription-manager attach.

Step 4: enabling the rhel6 repos is incorrect. You have 'subscription-manager repos --enable rhel—​ server-rpms \' should be 'subscription-manager repos --enable rhel—​6-server-rpms \'

step 5: prior to the 'yum repolist enabled', you want to issue a 'yum clean all'. This would clear out the metadata left over from those non-Red Hat yum repositories that we told the user to disable.

* Section 3.1.2

It might be advisable to redefine 'disconnected' here.

* Section 3.1.2.2.

step 4: add 'enabled=1' to the rhel7-server.repo file.
step 6: use the file name of a 6.2 iso. You have 'mount -o loop satellite-6.1.5-rhel-7-x86_64-dvd.iso /media/sat6'


* Section 3.2.1


It is stated 'If you configure Satellite Server to use custom certificates, you must do the same for all Capsule
Servers'. This statement is potentially ambiguous. The end user can interpret that as 'use the same certificates on all the servers', which would be bad.


it is stated 'The certificate’s Common Name (CN) must match the fully-qualified domain name of the
server on which it is used.' As a user, how do I check this before begining


* Section 3.3.1

Step 3: need to also ensure satellite can communicate with cert-api.access.redhat.com if Insights is being used


* Section 3.3.2

"You can configure DNS and DHCP on Satellite Server. TFTP is automatically configured." Is TFTP enabled by default now? I dont think it is.
Comment 1 Allison Heslin 2016-02-29 14:19:08 EST
As a result of the feedback received and due to the Quick Start Guide, I've reorganized the installation workflow that the Install Guide and QS Guide are in sync.

Section 3.1.1 - Step 2 looks wonky
[Ali] DONE

Section 3.1.2 - Steps look wonky too. 
[Ali] DONE



Section 3 Installing Satellite Server- This section describes both the connected and disconnected methods of installing Satellite, but then lists only the tasks for a connected installation.
[Ali] DONE The list has been removed since there are two installation methods.

3.1.1. Downloading and Installing from a Connected Network
Aren’t some of these commands duplicates of those in 2.5?
[Ali] DONE as part of the reorg work.

3.1.2. Downloading and Installing from a Disconnected Network
The disclaimers in this section make the disconnected option appear a substandard option, but it is not.

Response from Rich Jerrido - What we try to avoid is users installing old bits from ISO because of the 'sat5 way', where you could only install the product via ISO. We don't refresh the ISOs with every z-stream, so unless you absolutely have to, don't use them.

[Ali] DONE as no real action is required.

The following is stated as a prerequisite, but instructions for this task then appear in this section’s first procedure. “Ensure the latest Binary DVD images for both Satellite Server and the host (the base system) are present on, or accessible from, the base system.” 
[Ali] DONE Removed the pre-req since it's actually a task.

3.1.1 Downloading and Installing Satellite Server
Step 2: Change code block to # subscription-manager subscribe --pool= \
(Remove additional code)
[Ali] DONE

Step 3: Change to # subscription-manager repos --disable ‘’*’’
[Ali] DONE

Step 4: Change choice table to code blocks (universal change with RHEL 6 and 7 choices)
Change to --enable rhel-server-rhscl-6-rpms (missing the 6)
[Ali] DONE Added the 6. Did not change the table in this instance. Did change it in other instances.

3.1.2.2: Configuring the Base System with Offline Repositories
Step 6 change ISO version for Satellite (to 6.2)
[Ali] DONE

* Chapter 3 - Installing Satellite Server.

"You can obtain the packages necessary to install Satellite Server by either downloading them
directly from the Red Hat Content Delivery Network (CDN), by downloading an ISO image of the
packages from an external computer.
For hosts that have network connectivity, Red Hat recommends downloading the packages directly
from the CDN. Using ISO images is only recommended for hosts in a disconnected environment
because ISO images may not contain the latest updates."

suggested improvement

"You can obtain the packages necessary to install Satellite Server by either installing them
directly from the Red Hat Content Delivery Network (CDN) or by downloading an ISO image of the
packages from an external computer and copying it to the Satellite for installation.
For hosts that have network connectivity, Red Hat recommends installing the packages directly
from the CDN. Using ISO images is only recommended for hosts in a disconnected environment
because ISO images may not contain the latest updates."

[Ali] DONE

* Section 3.1.1

step 2: subscription-manager subscribe is deprecated. Use subscription-manager attach.
[Ali] DONE

Step 4: enabling the rhel6 repos is incorrect. You have 'subscription-manager repos --enable rhel—​ server-rpms \' should be 'subscription-manager repos --enable rhel—​6-server-rpms \'
[Ali] DONE

step 5: prior to the 'yum repolist enabled', you want to issue a 'yum clean all'. This would clear out the metadata left over from those non-Red Hat yum repositories that we told the user to disable.

* Section 3.1.2

[Ali] DONE

It might be advisable to redefine 'disconnected' here.
[Ali] DONE I used the above rewrite and defined both installation methods.

* Section 3.1.2.2.

step 4: add 'enabled=1' to the rhel7-server.repo file.
[Ali] DONE
step 6: use the file name of a 6.2 iso. You have 'mount -o loop satellite-6.1.5-rhel-7-x86_64-dvd.iso /media/sat6'
[Ali] DONE


* Section 3.2.1


It is stated 'If you configure Satellite Server to use custom certificates, you must do the same for all Capsule
Servers'. This statement is potentially ambiguous. The end user can interpret that as 'use the same certificates on all the servers', which would be bad.
[Ali] DONE Added: You must configure separate certificates for Satellite and Capsule Servers.
Comment 2 Allison Heslin 2016-03-02 13:46:27 EST
* Section 3.3.2

"You can configure DNS and DHCP on Satellite Server. TFTP is automatically configured." Is TFTP enabled by default now? I dont think it is.
[Ali] DONE Verified that it's not configured by default. Updated the topic.
Comment 3 Allison Heslin 2016-03-04 12:52:54 EST
* Section 3.3.1

Step 3: need to also ensure satellite can communicate with 
cert-api.access.redhat.com if Insights is being used
[Ali] DONE - Also added api.redhat.access.com per Lindani's review
Comment 4 Allison Heslin 2016-03-07 10:24:55 EST
*** Bug 1315026 has been marked as a duplicate of this bug. ***
Comment 5 Allison Heslin 2016-03-21 12:16:24 EDT
The remaining feedback about verifying the common name and host name of the custom certificate is a bit involved. Chris Roberts suggested opening a BZ to add it to the cert check script so that's what I'm going to do. Sending this to ON_QA since that was the last bit. 

Brandi-There's nothing left to check as far as Gitlab goes. Everything else has a merge request attached.
Comment 6 Andrew Dahms 2016-04-27 19:58:24 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.