Bug 1311174 - Add a NOTE or WARNING to NEVER redirect the java store underneath the rhq-agent directory
Add a NOTE or WARNING to NEVER redirect the java store underneath the rhq-age...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.0.1,JON 3.1.2,JON 3.2.3,JON 3.3.8
Unspecified Unspecified
high Severity high
: post-GA
: JON 3.3.8
Assigned To: Tyler Kelly
Mike Foley
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 09:44 EST by dsteigne
Modified: 2017-08-25 00:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-25 00:54:26 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 24321 None None None 2016-02-23 09:49 EST

  None (edit)
Description dsteigne 2016-02-23 09:44:37 EST
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Operations_Network/3.3/html-single/Admin_and_Config/index.html#setting-in-java-opts
Section Number and Name: 

Describe the issue: 
Add a NOTE or WARNING to NEVER redirect the java store underneath the rhq-agent directory as it will get overwritten on an agent update/upgrade.
Suggestions for improvement: 

Additional information:
Comment 1 dsteigne 2016-02-23 09:50:41 EST
To be more specific the /rhq-agent runtime directory.
Comment 2 Tyler Kelly 2017-07-23 23:09:37 EDT
Added "important" note to the end of the section:
Do not set the Java option within the rhq-agent runtime directory because this file is overwritten during &JON; agent updates. The default location for the rhq-agent runtime is <filename>$USERHOME/.java/.userPrefs/rhq-agent/default</filename>.

3.3
    Git Commit:
https://gitlab.cee.redhat.com/tkelly/doc-jon-docs/commit/fece5655f14117a572823909162dd8fab39d2a18
    Merge Request:
https://gitlab.cee.redhat.com/red-hat-jboss-operations-network-documentation/doc-jon-docs/merge_requests/38
    Pantheon Preview:
https://access.qa.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.3/html-single/admin_and_config/#setting-in-java-opts

3.2
    Git Commit:
https://gitlab.cee.redhat.com/tkelly/jon32/commit/8dbd9c3883dc34d00bc9a906e8783599cd4d2b1e
    Merge Request:
https://gitlab.cee.redhat.com/red-hat-jboss-operations-network-documentation/jon32/merge_requests/5
    Pantheon Preview:
https://access.qa.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.2/html-single/admin_and_config/#setting-in-java-opts

3.1
    Git Commit:
https://gitlab.cee.redhat.com/tkelly/jon31/commit/b36399f50f9d71a3c0904cae538d4f4af5183c19
    Merge Request:
https://gitlab.cee.redhat.com/red-hat-jboss-operations-network-documentation/jon31/merge_requests/13
    Pantheon Preview:
https://access.qa.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.1/html-single/admin_configuring_jon_servers_and_agents/#setting-in-java-opts
https://access.qa.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.1/html-single/installation_guide/#setting-in-java-opts

3.0 - Added to warning within the installation guide:
    Git Commit:
https://gitlab.cee.redhat.com/tkelly/jon30/commit/6084a7f4f5d5d2579abc57b8209e0581ac0a8aeb
    Merge Request:
https://gitlab.cee.redhat.com/red-hat-jboss-operations-network-documentation/jon30/merge_requests/4
    Pantheon Preview:
https://access.qa.redhat.com/documentation/en-us/red_hat_jboss_operations_network/3.0/html-single/installation_guide/#Preparing_the_Agent

Note You need to log in before you can comment on or make changes to this bug.