Bug 1311182 - Address feedback on Chapter 6
Address feedback on Chapter 6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
Unspecified
Unspecified Unspecified
medium Severity medium (vote)
: Beta
: 6.2
Assigned To: Allison Heslin
Brandi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 09:51 EST by Allison Heslin
Modified: 2016-06-16 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 00:21:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allison Heslin 2016-02-23 09:51:48 EST
* Section 6.1.2 - Talk to cfouant about adding more detail about how to take a backup.

* Section 6.1.3 - This seems like we have crossed from installation into configuration

6.1.2: Upgrading Satellite Server
Before You Begin: Remove last 3 bullets

Step 1: physical machine backup: Need to call out that users need a lot of storage where the backup is saved, basically double because it saves everything.

Step 2: Remove weird tilde and command. Should just be yum update
Tell user that if they don’t have any new packages they can proceed.

If they have new packages, they need to first run katello-installer --upgrade (even though this is a pre-req, we should still call it out so the upgrade doesn’t fail)

6.1.3: Enabling New Repositories
Menu cascade isn’t showing (check globally that this is working elsewhere)

6.2 Upgrading Disconnected Satellite - Need clarification on how to do the upgrade for disconnected Satellite. ISS might replace this?

6.2.2: Step 2: Code block - fix Ascii Doc

6.3 Upgrading Capsule Server
Repeat of Satellite Server section -- must have latest minor version before upgrading. 


6.5: Upgrade Satellite Clients
Question for Rich or Development: Is this the way that we want users to do this? Or should we direct them to use the web UI?
Step 2 is a prereq

Chapter 6:

We state supported upgrade paths. We should also state unsupported upgrade paths.

Section 6.1.2

"On a physical machine, create a backup by running the 'katello-service stop' command.". It should be 'On a physical machine, create a backup by running the 'katello-backup' command.

Section 6.1.2.

what is the ` doing in the command example? 

General:

There are a number of instances where we give RHEL6 examples before RHEL7 and later the other way around. Did we want to be more consistent with this? If so, I’d recommend RHEL6 first.
Comment 1 Allison Heslin 2016-03-03 13:31:59 EST
6.1.2: Upgrading Satellite Server
Before You Begin: Remove last 3 bullets
[Ali] DONE

Step 2: Remove weird tilde and command. Should just be yum update
[Ali] DONE
Tell user that if they don’t have any new packages they can proceed.
[Ali] DONE

If they have new packages, they need to first run katello-installer --upgrade (even though this is a pre-req, we should still call it out so the upgrade doesn’t fail)
[Ali] DONE

6.1.3: Enabling New Repositories
Menu cascade isn’t showing (check globally that this is working elsewhere)
[Ali] DONE Not seeing this anymore.

6.2.2: Step 2: Code block - fix Ascii Doc
[Ali] DONE

6.3 Upgrading Capsule Server
Repeat of Satellite Server section -- must have latest minor version before upgrading. 
[Ali] DONE

Section 6.1.2

"On a physical machine, create a backup by running the 'katello-service stop' command.". It should be 'On a physical machine, create a backup by running the 'katello-backup' command.
[Ali] DONE

Section 6.1.2.

what is the ` doing in the command example? 
[Ali] DONE it's removed
Comment 2 Allison Heslin 2016-03-08 11:10:24 EST
6.5: Upgrade Satellite Clients
Question for Rich or Development: Is this the way that we want users to do this? Or should we direct them to use the web UI?
[Ali] DONE Upgrade is CLI only per Rich. No change required.

We state supported upgrade paths. We should also state unsupported upgrade paths.
[Ali] DONE No change required since we call out the supported upgrade paths.
Comment 3 Allison Heslin 2016-03-08 11:52:02 EST
* Section 6.1.3 - This seems like we have crossed from installation into configuration
[Ali] DONE - Removed this step per Eric and Bryan.
Comment 4 Allison Heslin 2016-03-08 11:52:34 EST
This is what's left:

* Section 6.1.2 - Talk to cfouant about adding more detail about how to take a backup.
[Ali] There's another bug covering backups and I think it might be better tracked there.

Step 1: physical machine backup: Need to call out that users need a lot of storage where the backup is saved, basically double because it saves everything.
[Ali] This is part of the backup process. Maybe we should move this to that procedure?

6.2 Upgrading Disconnected Satellite - Need clarification on how to do the upgrade for disconnected Satellite. ISS might replace this?
[Ali] Check with Andrew about this?
Comment 5 Mike McCune 2016-03-28 18:13:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 Allison Heslin 2016-06-01 15:25:01 EDT
Spoke with DPM and because the above comments are covered by other bugs, I'm closing this one.
Comment 7 Allison Heslin 2016-06-01 15:25:02 EDT
Spoke with DPM and because the above comments are covered by other bugs, I'm closing this one.
Comment 8 Allison Heslin 2016-06-01 15:25:20 EDT
Spoke with DPM and because the above comments are covered by other bugs, I'm closing this one.
Comment 9 Andrew Dahms 2016-06-16 00:21:50 EDT
Moving to closed.

Note You need to log in before you can comment on or make changes to this bug.