Bug 1311213 - EDS 5.3 jdbc driver virtual procedure call against JDV 6.2.3
EDS 5.3 jdbc driver virtual procedure call against JDV 6.2.3
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid, Documentation (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.3.0
Assigned To: David Le Sage
Filip Elias
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 10:28 EST by Jan Stastny
Modified: 2016-08-11 01:04 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: Using a driver from a prior major release against a new major release. Consequence: The user may see errors due to incompatibilities between major versions Workaround (if any): The user should be instructed to upgrade their driver. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 01:04:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3998 Major Closed EDS 5.3 jdbc driver virtual procedure call against JDV 6.2.3 2016-08-10 19:21 EDT

  None (edit)
Description Jan Stastny 2016-02-23 10:28:31 EST
Description of problem:
We identified an issue when trying to connect with EDS 5.3 jdbc driver to JDV 6.2.3 instance.
The problem is caused by virtual procedure execution.
Query performed:
EXEC View.hiddenUpdate(456,'changed')

View definition:
<model name="View" type="VIRTUAL">
   <metadata type="DDL"><![CDATA[
	CREATE VIRTUAL PROCEDURE hiddenUpdate(ID integer,CUSTOMERNAME string) AS BEGIN
   MERGE INTO Customers(id,customername) VALUES(ID,CUSTOMERNAME);
END
]]> </metadata>
</model>
Comment 1 JBoss JIRA Server 2016-02-24 13:10:15 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3998 to Resolved
Comment 2 Van Halbert 2016-03-05 11:42:10 EST
This is a client side issue, as the engineer indicated (and fixed in 6.x).  Therefore, there is no fix to help the use of the EDS 5.3 jdbc driver, other than document this and suggest they upgrade their driver to 6.x if this issue arrives.
Comment 3 JBoss JIRA Server 2016-06-03 18:43:31 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3998 to Closed

Note You need to log in before you can comment on or make changes to this bug.