Bug 1311248 - akondai does not start
akondai does not start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kf5-akonadi-server (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 12:49 EST by Dennis Gilmore
Modified: 2016-04-30 22:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-30 22:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2016-02-23 12:49:05 EST
Description of problem:

QSqlDatabase: QMYSQL driver not loaded
QSqlDatabase: available drivers: QSQLITE QSQLITE3 QMYSQL QMYSQL3
Invalid database object during database server startup


Version-Release number of selected component (if applicable):
kf5-akonadi-server-15.12.2-1.fc24.x86_64

How reproducible:
after upgrade from f23 akondai refuses to start

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Dennis Gilmore 2016-02-23 15:38:37 EST
2016-02-23 14:36:47 7fc93b14c8c0 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: The InnoDB memory heap is disabled
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Memory barrier is not used
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Compressed tables use zlib 1.2.8
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Using Linux native AIO
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Using SSE crc32 instructions
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Initializing buffer pool, size = 80.0M
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Completed initialization of buffer pool
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Highest supported file format is Barracuda.
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: 128 rollback segment(s) are active.
2016-02-23 14:36:47 140502256371904 [Note] InnoDB: Waiting for purge to start
2016-02-23 14:36:47 140502256371904 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.26-76.0 started; log sequence number 73582217978
2016-02-23 14:36:47 140501592303360 [Note] InnoDB: Dumping buffer pool(s) not yet started
2016-02-23 14:36:47 140502256371904 [Note] Plugin 'FEEDBACK' is disabled.
2016-02-23 14:36:47 7fc93b06cb00 InnoDB: Error: Column last_update in table "mysql"."innodb_table_stats" is INT UNSIGNED NOT NULL but should be BINARY(4) NOT NULL (type mismatch).
2016-02-23 14:36:47 7fc93b06cb00 InnoDB: Error: Fetch of persistent statistics requested for table "mysql"."gtid_slave_pos" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2016-02-23 14:36:47 140502256371904 [Note] Reading of all Master_info entries succeded
2016-02-23 14:36:47 140502256371904 [Note] Added new Master_info '' to hash table
2016-02-23 14:36:47 140502256371904 [Note] /usr/libexec/mysqld: ready for connections.
Version: '10.1.11-MariaDB'  socket: '/tmp/akonadi-dennis.iIS5Ww/mysql.socket'  port: 0  MariaDB Server
2016-02-23 14:36:47 140502140640000 [Note] /usr/libexec/mysqld: Normal shutdown

2016-02-23 14:36:47 140501575517952 [Note] InnoDB: FTS optimize thread exiting.
2016-02-23 14:36:47 140502140640000 [Note] InnoDB: Starting shutdown...
2016-02-23 14:36:49 140502140640000 [Note] InnoDB: Shutdown completed; log sequence number 73582217988
2016-02-23 14:36:49 140502140640000 [Note] /usr/libexec/mysqld: Shutdown complete
Comment 2 Martin Kho 2016-02-27 07:49:00 EST
Hi,

This happend to me after the upgrade to mariadb 10.1.11. Downgrading to version 10.1.8 'solves' it.

Martin Kho
Comment 3 Rex Dieter 2016-04-30 22:16:41 EDT
looks like this should be fixed now with latest akonadi + mariadb 10.1.14

For me, initial:

$ akonadictl start

Installing MariaDB/MySQL system tables in '/home/rdieter1/.local/share/akonadi/db_data/' ...
2016-04-30 21:14:31 140018940893376 [Note] /usr/libexec/mysqld (mysqld 10.1.13-MariaDB) starting as process 21358 ...

Filling help tables...
at2016-04-30 21:14:43 140107641993408 [Note] /usr/libexec/mysqld (mysqld 10.1.13-MariaDB) starting as process 21495 ...
OK
Creating OpenGIS required SP-s...
2016-04-30 21:14:45 139780471765184 [Note] /usr/libexec/mysqld (mysqld 10.1.13-MariaDB) starting as process 21565 ...
OK

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MariaDB root USER !
To do so, start the server, then issue the following commands:

'/usr/bin/mysqladmin' -u root password 'new-password'
'/usr/bin/mysqladmin' -u root -h localhost.localdomain password 'new-password'

Alternatively you can run:
'/usr/bin/mysql_secure_installation'

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the MariaDB Knowledgebase at http://mariadb.com/kb or the
MySQL manual for more instructions.

You can start the MariaDB daemon with:
cd '/usr' ; /usr/bin/mysqld_safe --datadir='/home/rdieter1/.local/share/akonadi/db_data/'

You can test the MariaDB daemon with mysql-test-run.pl
cd '/usr/mysql-test' ; perl mysql-test-run.pl

Please report any problems at http://mariadb.org/jira

The latest information about MariaDB is available at http://mariadb.org/.
You can find additional information about the MySQL part at:
http://dev.mysql.com
Support MariaDB development by buying support/new features from MariaDB
Corporation Ab. You can contact us about this at sales@mariadb.com.
Alternatively consider joining our community based development effort:
http://mariadb.com/kb/en/contributing-to-the-mariadb-project/

mysql.column_stats                                 OK
mysql.columns_priv                                 OK
mysql.db                                           OK
mysql.event                                        OK
mysql.func                                         OK
mysql.gtid_slave_pos                               OK
mysql.help_category                                OK
mysql.help_keyword                                 OK
mysql.help_relation                                OK
mysql.help_topic                                   OK
mysql.host                                         OK
mysql.index_stats                                  OK
mysql.innodb_index_stats                           OK
mysql.innodb_table_stats                           OK
mysql.plugin                                       OK
mysql.proc                                         OK
mysql.procs_priv                                   OK
mysql.proxies_priv                                 OK
mysql.roles_mapping                                OK
mysql.servers                                      OK
mysql.table_stats                                  OK
mysql.tables_priv                                  OK
mysql.time_zone                                    OK
mysql.time_zone_leap_second                        OK
mysql.time_zone_name                               OK
mysql.time_zone_transition                         OK
mysql.time_zone_transition_type                    OK
mysql.user                                         OK


$ akonadictl status
Akonadi Control: running
Akonadi Server: running
search paths:  ("lib64", "lib64/qt5/plugins/", "lib64/kf5/", "lib64/kf5/plugins/", "/usr/lib/qt5/plugins/", "/usr/lib64/qt5/plugins", "/usr/bin")
Akonadi Server Search Support: available (Remote Search)
Available Agent Types: akonadi_akonotes_resource, akonadi_archivemail_agent, akonadi_birthdays_resource, akonadi_contacts_resource, akonadi_davgroupware_resource, akonadi_followupreminder_agent, akonadi_googlecalendar_resource, akonadi_googlecontacts_resource, akonadi_ical_resource, akonadi_icaldir_resource, akonadi_imap_resource, akonadi_indexing_agent, akonadi_invitations_agent, akonadi_kalarm_dir_resource, akonadi_kalarm_resource, akonadi_maildir_resource, akonadi_maildispatcher_agent, akonadi_mailfilter_agent, akonadi_mbox_resource, akonadi_migration_agent, akonadi_mixedmaildir_resource, akonadi_newmailnotifier_agent, akonadi_notes_agent, akonadi_notes_resource, akonadi_openxchange_resource, akonadi_pop3_resource, akonadi_sendlater_agent, akonadi_vcard_resource, akonadi_vcarddir_resource

Note You need to log in before you can comment on or make changes to this bug.