This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1311284 - M-x man does not complete recently-installed man pages
M-x man does not complete recently-installed man pages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: man-db (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-23 15:12 EST by Robin Green
Modified: 2016-03-13 19:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: man-db-2.7.1-11.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-13 19:53:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2016-02-23 15:12:09 EST
Description of problem:
M-x man does not complete man pages that have recently been installed. However, it displays them just fine.

Version-Release number of selected component (if applicable):
emacs-24.5-7.fc23.x86_64

How reproducible:
Always

Steps to Reproduce:
1. sudo dnf install autofs
2. In emacs, M-x man
3. auto <TAB>

Actual results:
Possible completions are:
AutoLoader(3pm) 	AutoSplit(3pm)
autoconf(1) 	autodie(3pm)
autodie::Scope::Guard(3pm) 	autodie::Scope::GuardStack(3pm)
autodie::Util(3pm) 	autodie::exception(3pm)
autodie::exception::system(3pm) 	autodie::hints(3pm)
autodie::skip(3pm) 	autoheader(1)
autom4te(1) 	automake(1)
automake-1.15(1) 	autopoint(1)
autoreconf(1) 	autoscan(1)
autoupdate(1) 	autouse(3pm)

Expected results:
Should include autofs(8) and autofs.conf(5). It is not about the section, because resolv.conf(5) _is_ completed correctly.
Comment 1 Robin Green 2016-02-23 15:13:49 EST
Maybe this is actually a bug in the autofs rpm spec file - maybe it should ensure the man page "cache" that is evidently being used here (whatever it is) is updated?
Comment 2 Jan Synacek 2016-03-08 05:36:05 EST
Probably not, since spec files usually don't invoke mandb directly. Running mandb after installing the package solves the issue.

I don't know how rpm uses the man cache when it installs packages containing man pages. Could anybody from the rpm team please advise?
Comment 3 Jan Chaloupka 2016-03-08 06:03:45 EST
The cache is maintained by man-db.
Comment 4 Colin Watson 2016-03-08 06:43:16 EST
This is supposed to be handled by the %transfiletriggerin (etc.) trigger in man-db's spec file.  That's probably the place to start looking.
Comment 5 Nikola Forró 2016-03-08 06:45:50 EST
In F23, the man cache is updated daily by a cron job. In F24, starting with version 2.7.3-2.fc24, man-db takes advantage of new rpm feature called file triggers and man cache update is triggered after installation of any package containing man pages.
Since rpm in F23 also supports file triggers, I will rebase man-db in F23 to solve this issue.
Comment 7 Fedora Update System 2016-03-08 09:59:28 EST
man-db-2.7.1-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea371ced65
Comment 8 Fedora Update System 2016-03-09 17:56:24 EST
man-db-2.7.1-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ea371ced65
Comment 9 Fedora Update System 2016-03-13 19:53:46 EDT
man-db-2.7.1-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.