Bug 1311319 - Tenant quota - Sub-tenants are allowed resources when top tenant resources are exhausted .
Tenant quota - Sub-tenants are allowed resources when top tenant resources ar...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.6.0
Unspecified Unspecified
unspecified Severity high
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Pavol Kotvan
tenant_cfme:quota
:
Depends On:
Blocks: cfme_fastweb
  Show dependency treegraph
 
Reported: 2016-02-23 18:04 EST by William Fitzgerald
Modified: 2017-08-21 09:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 09:07:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Quota- Tenant My Company exceeded (997.70 KB, image/png)
2016-02-23 18:04 EST, William Fitzgerald
no flags Details
Quota - Child Tenant allowing after Tenant exceeded (992.09 KB, image/png)
2016-02-23 18:05 EST, William Fitzgerald
no flags Details

  None (edit)
Description William Fitzgerald 2016-02-23 18:04:22 EST
Created attachment 1129950 [details]
Quota- Tenant My Company exceeded

Description of problem:
Child Tenants are allowed resources when Top Tenant resources are exhausted.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:

Using the explorer, Navigate to Configure/Configuration/
-> Access Control -> Tenants

Select Tenant 'My Company' from left panel

1. Create Child Tenant under Top Tenant.
2. Create Child Tenant user.
3. Configure quota for Top Tenant to be less than available resources.

*See Attachment : Quota - Tenant My Company exceeded Screen Shot

*note: To determine available resources, set all quota values to 1 and 
real values will be displayed.

4. Configure quota for Child Tenant to exceed available resources. 

*See Attachment : Quota - Child Tenant allowing after Tenant exceeded 
Screen Shot

5. Provision as top tenant user to see failed quota check.
6. Provision as Child Tenant user to see passed quota check.

Actual results:
Child Tenant provision request passed quota check.

Expected results:
Child Tenant provision request should have failed quota check.

Additional info:
Comment 2 William Fitzgerald 2016-02-23 18:05 EST
Created attachment 1129952 [details]
Quota - Child Tenant allowing after Tenant exceeded
Comment 3 Chris Pelland 2017-08-21 09:07:33 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 4 Chris Pelland 2017-08-21 09:09:50 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.