Bug 1311371 - [RFE] Enable puppet to modify 'default_floating_pool' used by nova api [NEEDINFO]
[RFE] Enable puppet to modify 'default_floating_pool' used by nova api
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Angus Thomas
Arik Chernetsky
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 00:22 EST by Jaison Raju
Modified: 2017-01-24 16:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-24 16:24:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jraju: needinfo? (athomas)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2249311 None None None 2016-04-10 11:48 EDT

  None (edit)
Description Jaison Raju 2016-02-24 00:22:36 EST
1. Proposed title of this feature request  
      Enable puppet to modify 'default_floating_pool' used by nova api .

    3. What is the nature and description of the request?  
default_floating_pool is an parameter used by nova api to talk to
neutron server and associate floating IP to servers from the public
network. Upstream default is 'nova', let's keep it but at least this
patch allows to change the parameter.
      
    4. Why does the customer need this? (List the business requirements here)
      Need to non default value (nova) for this variable .
      Causing few tempest tests to fail with this ability .
      
    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
      
https://github.com/openstack/puppet-nova/commit/83ea9464a5c99733521541095104fa34d6ee2614
Comment 3 Emilien Macchi 2016-02-24 11:14:07 EST
There is no bug in puppet-nova, since we already provide the interface to configure default_floating_pool in ::nova::api class, like you mentioned with the commit.

Which installer are you using?
Comment 4 Jaison Raju 2016-03-25 00:37:23 EDT
(In reply to Emilien Macchi from comment #3)
> There is no bug in puppet-nova, since we already provide the interface to
> configure default_floating_pool in ::nova::api class, like you mentioned
> with the commit.
I am sorry , you are right :
#  grep -r default_floating /usr/share/openstack-puppet/
/usr/share/openstack-puppet/modules/nova/manifests/api.pp:# [*default_floating_pool*]
/usr/share/openstack-puppet/modules/nova/manifests/api.pp:  $default_floating_pool     = 'nova',
/usr/share/openstack-puppet/modules/nova/manifests/api.pp:    'DEFAULT/default_floating_pool':     value => $default_floating_pool;
/usr/share/openstack-puppet/modules/nova/CHANGELOG.md:- api: add default_floating_pool parameter

But not sure why , when i check the src rpm files , i couldn't find it .
$ grep floating openstack-puppet-modules-2015.1.8-51.el7ost/SOURCES/openstack-puppet-modules-2015.1.8/nova/manifests/api.pp
[No Results]


> 
> Which installer are you using?

I am checking with customer now . Customer may have made the same mistake as I did .
Comment 7 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Note You need to log in before you can comment on or make changes to this bug.