Bug 1311382 - keystone-manage db_sync failed
keystone-manage db_sync failed
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Adam Young
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 01:23 EST by Kaihua Chen
Modified: 2016-04-26 14:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 01:55:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
controller log (1.42 MB, text/x-vhdl)
2016-03-02 01:16 EST, Kaihua Chen
no flags Details

  None (edit)
Description Kaihua Chen 2016-02-24 01:23:41 EST
Description of problem:
After deployed the overcloud, we found some authentication error or URL error from os-collect-config log. When checking the database service running su -s /bin/sh -c "keystone-manage db_sync" keystone

We get error 
No handlers could be found for logger "oslo_config.cfg"

Version-Release number of selected component (if applicable):
Latest OSP8 beta version

How reproducible:
Always

Steps to Reproduce:
1. deploy overcloud 
2. run su -s /bin/sh -c "keystone-manage db_sync" keystone
3. get error No handlers could be found for logger "oslo_config.cfg"

Actual results:
No handlers could be found for logger "oslo_config.cfg"

Expected results:
The command should return no error

Additional info:
We are in trouble to deploy the OSP8 beta version in our system. We'd like to know where is the problem for our failure. From the os log, we found many related error below. Please note we have also create another case https://bugzilla.redhat.com/show_bug.cgi?id=1310956 on the same system.

While checked the controller node log. we found that following errors.
Feb 22 23:06:26 overcloud-controller-0.localdomain os-collect-config[10347]: [2016-02-22 23:06:26,639] (os-refresh-config) [INFO] Completed phase post-configure
Feb 22 23:06:28 overcloud-controller-0.localdomain os-collect-config[10347]: 2016-02-22 23:06:28.294 10347 WARNING os-collect-config [-] Source [request] Unavailable.
Feb 22 23:06:28 overcloud-controller-0.localdomain os-collect-config[10347]: 2016-02-22 23:06:28.295 10347 WARNING os_collect_config.local [-] /var/lib/os-collect-config/local-data not found. Skipping
Feb 22 23:06:28 overcloud-controller-0.localdomain os-collect-config[10347]: 2016-02-22 23:06:28.295 10347 WARNING os_collect_config.local [-] No local metadata found (['/var/lib/os-collect-config/local-data'])
Feb 22 23:06:28 overcloud-controller-0.localdomain os-collect-config[10347]: 2016-02-22 23:06:28.295 10347 WARNING os_collect_config.zaqar [-] No auth_url configured.
Comment 2 Kaihua Chen 2016-02-24 02:51:05 EST
[heat-admin@overcloud-controller-0 ~]$ openstack endpoint list
Unable to establish connection to http://overcloud-controller-0:35357/v3/endpoints
[heat-admin@overcloud-controller-0 ~]$ sudo netstat -anp |grep 35357
tcp        0      0 192.168.2.17:35357      0.0.0.0:*               LISTEN      18125/python2
tcp        0      0 192.168.2.17:35357      192.168.2.17:33580      SYN_RECV    -
tcp        0      0 192.168.2.16:35357      0.0.0.0:*               LISTEN      28363/haproxy
tcp        0      0 10.1.1.2:35357          0.0.0.0:*               LISTEN      28363/haproxy
Comment 4 Kaihua Chen 2016-02-26 02:34:26 EST
Hi Adam,


Thanks for your checking, which information do you need to check this issue exactly? Thanks.
Comment 5 Kaihua Chen 2016-03-02 01:15:57 EST
We tried on the latest beta 7 code, but still cannot fix this issue. Attach the OS collect log from the controller.
Comment 6 Kaihua Chen 2016-03-02 01:16 EST
Created attachment 1132149 [details]
controller log
Comment 7 Kaihua Chen 2016-03-08 01:55:42 EST
This case can be closed because the Overcloud is deployed with help of Redhat experts. The affiliate case number is 1310956.

Note You need to log in before you can comment on or make changes to this bug.