Bug 1311487 - SVG to TIFF conversion fails with org.apache.batik.transcoder.TranscoderException: null
SVG to TIFF conversion fails with org.apache.batik.transcoder.TranscoderExcep...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: batik (Show other bugs)
6.8
ppc64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Java maintainers
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 05:52 EST by Jiri Prajzner
Modified: 2016-02-25 03:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 03:35:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Prajzner 2016-02-24 05:52:57 EST
Description of problem:
When converting an SVG to TIFF, batik fails with org.apache.batik.transcoder.TranscoderException: null on PPC arch

Version-Release number of selected component (if applicable):
batik-1.7
java version "1.5.0"
gij (GNU libgcj) version 4.4.7 20120313 (Red Hat 4.4.7-17)

How reproducible:
Always

Steps to Reproduce:
1. ./build.sh svgrasterizer -m image/tiff samples/anne.svg -d ~
2.
3.

Actual results:
org.apache.batik.transcoder.TranscoderException: null
Enclosed Exception:
Could not write TIFF file because no WriteAdapter is availble
   at org.apache.batik.transcoder.image.ImageTranscoder.transcode(Unknown Source)
   at org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(Unknown Source)
   at org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(Unknown Source)
   at org.apache.batik.apps.rasterizer.SVGConverter.transcode(Unknown Source)
   at org.apache.batik.apps.rasterizer.SVGConverter.execute(Unknown Source)
   at org.apache.batik.apps.rasterizer.Main.execute(Unknown Source)
   at org.apache.batik.apps.rasterizer.Main.main(Unknown Source)
Converting anne.svg to /root/anne.tif ... ... error (SVGConverter.error.while.rasterizing.file)

Expected results:
Successful SVG to TIFF conversion

Additional info:
There seem to be two WriteAdapter options that are currently not present on the target architecture: 
- org.apache.batik.ext.awt.image.codec.tiff.TIFFTranscoderInternalCodecWriteAdapter
- org.apache.batik.transcoder.image.TIFFTranscoderImageIOWriteAdapter

Both should be available in batik-codec JAR.
Comment 2 Mikolaj Izdebski 2016-02-24 10:16:01 EST
I don't see batik available for ppc64 (it has ExclusiveArch: x86_64 i686, see rhbz#598152). Where did you get the package from?
Comment 3 Jiri Prajzner 2016-02-24 10:25:35 EST
http://download.devel.redhat.com/brewroot/packages/batik/1.7/10.el6/src/batik-1.7-10.el6.src.rpm

It was upstream test rpmbuild/SOURCE/batik-src*.zip
Comment 4 Mikolaj Izdebski 2016-02-25 03:30:16 EST
This package was not designed to work on ppc64 architecture. It is supported only on x86_64 and i686. For more information see bug #598152.
Comment 5 RHEL Product and Program Management 2016-02-25 03:35:55 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.