Bug 1311548 - Kickstart install with static ip configures interface with DHCP AND static IP
Kickstart install with static ip configures interface with DHCP AND static IP
Status: CLOSED DUPLICATE of bug 1272274
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 07:51 EST by jorge.gonzalez
Modified: 2016-02-24 09:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-24 09:23:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jorge.gonzalez 2016-02-24 07:51:00 EST
Description of problem:

I have the following lines in a KS file for a 3 NIC VM:

...
network  --bootproto static --device eth0 --ip 192.168.122.13 --netmask 255.255.255.0 --gateway 192.168.122.1 --nameserver 8.8.8.8 --noipv6 --activate
network  --hostname=$hostname
network  --bootproto=static --device=eth1 --ip=192.168.10.254 --netmask=255.255.255.0 --noipv6 --activate
network  --bootproto=static --device=eth2 --ip=192.168.20.254 --netmask=255.255.255.0 --noipv6 --activate
...

When the installation finishes, two IPs for the same subnet are assigned to the same interface eth0, and the DHCP client also running for eth0. One of the IPs is the static I specified, and the other one is being set by the DHCP client, which is running on that interface.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a KS install with the provided network options
2. Launch kickstart install with that file
3. Check network configuration of installed machine

Actual results:

This is the (strange) content of /etc/sysconfig/network-scripts/ifcfg-eth0:

TYPE=Ethernet
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
NAME=eth0
UUID=d3ef4a32-7d1d-49af-af1f-939c1d641dc7
DEVICE=eth0
ONBOOT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPADDR=192.168.122.13
PREFIX=24
GATEWAY=192.168.122.1
PEERDNS=yes
PEERROUTES=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes

The boot protocol is being set to "dhcp", BUT it is being assigned a static IP address too.

On ifcfg-eth1 and ifcfg-eth2 the BOOTPROTO variable is also being ignored from the kickstart "network --bootproto" directive. This is the content of the generated /etc/sysconfig/network-scripts/ifcfg-eth1:

# Generated by parse-kickstart
UUID=1dc6dae2-4cef-458c-8318-b8f390f52750
BOOTPROTO=none
DEVICE=eth1
ONBOOT=yes
IPV6INIT=no
TYPE=Ethernet
IPADDR=192.168.10.254
PREFIX=24
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
NAME="System eth1"

ifcfg-etth2 is similarly defined, with BOOTPROTO=none.

It seems that the bootproto option is not being honored when configuring the interfaces.

Expected results:

All ifcfg-ethX config files should have the BOOTPROTO=static in them, instead of the wrong ones.

Additional info:
Comment 2 Radek Vykydal 2016-02-24 09:23:16 EST
This bug should be fixed in RHEL 7.3.
Possible workarounds:
- move the --hostname option to some of other network commands
- make the network --hostname the first network command
- add nonexisting --device= to the hostname command

*** This bug has been marked as a duplicate of bug 1272274 ***

Note You need to log in before you can comment on or make changes to this bug.