Bug 1311663 - False positives in every abrt "sensitive words" search
False positives in every abrt "sensitive words" search
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 12:10 EST by Jonathan Wakely
Modified: 2016-04-21 21:24 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreport-2.6.4-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 21:24:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Wakely 2016-02-24 12:10:56 EST
Every backtrace I submit using abrt has the same shared library, and abrt flags it up as a sensitive word. libxcb-keysyms.so is not a "key" so it's just an annoying false positive that makes me check the "backtrace" and "maps" tabs every time.

Likewise, PAM_KWALLET_LOGIN=/tmp/kwallet_jwakely.socket is not a "login" and should not be flagged in the "environ" tab.

Please filter out these false positives automatically.
Comment 1 Jonathan Wakely 2016-03-23 18:12:14 EDT
Apparently libxcb-keysyms.so.1 just needs to be added to /etc/libreport/ignored_words.conf
Comment 2 Matej Habrnal 2016-04-08 06:41:49 EDT
This commit fixes the issue:
https://github.com/abrt/libreport/commit/31286e80a4182299f774eb381c0023335caa5a3e
Comment 3 Jonathan Wakely 2016-04-08 08:21:41 EDT
Thanks!

As I noted on github, ignoring "kwallet_jwakely" is probably only useful for me, not every other user of libreport. Ignoring PAM_KWALLET_LOGIN should be sufficient, because it's the string "LOGIN" that caused the problem. The kwallet_jwakely part shouldn't get flagged up anyway.
Comment 4 Fedora Update System 2016-04-11 10:26:08 EDT
abrt-2.8.0-4.fc23 libreport-2.6.4-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bdef912372
Comment 5 Fedora Update System 2016-04-13 05:28:06 EDT
abrt-2.8.0-4.fc23, libreport-2.6.4-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bdef912372
Comment 6 Fedora Update System 2016-04-21 21:24:19 EDT
abrt-2.8.0-4.fc23, libreport-2.6.4-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.