Bug 131171 - libselinux compiled without optimization
libselinux compiled without optimization
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 01:14 EDT by Ulrich Drepper
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 12:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-08-28 01:14:33 EDT
Description of problem:
While good for debugging, not so good for deployment.  And libselinux
is deployed.  So add optimization.

Version-Release number of selected component (if applicable):
libselinux-1.17.1-1

How reproducible:
always

Steps to Reproduce:
1.rpmbuild -bc libselinux.spec
2.observe compiler command lines
3.
  
Actual results:
cc -Wall -I../include  -c -o freecon.o freecon.c


Expected results:
cc -O2 -march=pentium4 -I../include  -c -o freecon.o freecon.c


Additional info:

Apply this patch.

--- SPECS/libselinux.spec-O0    2004-08-27 21:33:50.000000000 -0700
+++ SPECS/libselinux.spec       2004-08-27 21:33:04.000000000 -0700
@@ -37,7 +37,7 @@
 %setup -q
  
 %build
-make
+make CFLAGS="-g %{optflags}"
  
 %install
 rm -rf ${RPM_BUILD_ROOT}
Comment 1 Daniel Walsh 2004-08-30 09:45:40 EDT
Added 
make CFLAGS="%{optflags}"

Since -g was already there.

Dan

libselinux-1_17_4-1
Comment 2 Ulrich Drepper 2004-10-14 22:39:28 EDT
No, Dan, -g is not there anymore.  All the files are compiled without
-g now and the .debuginfo files are worthless.  Please use the patch I
provided.
Comment 3 Daniel Walsh 2004-10-15 09:39:32 EDT
libselinux-1.17.15-1.rpm has this change.
Comment 4 Ulrich Drepper 2004-10-15 12:40:39 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.