Bug 1311735 - grub.cfg not functionnal after upgrade 7.1 to 7.3, impossible to reboot nodes
grub.cfg not functionnal after upgrade 7.1 to 7.3, impossible to reboot nodes
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity urgent
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
Arik Chernetsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 15:57 EST by Nicolas Hicher
Modified: 2016-03-15 11:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 11:30:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
templates and grub.cfg files (40.00 KB, application/x-tar)
2016-02-24 15:57 EST, Nicolas Hicher
no flags Details

  None (edit)
Description Nicolas Hicher 2016-02-24 15:57:17 EST
Created attachment 1130332 [details]
templates and grub.cfg files

Description of problem:


Version-Release number of selected component (if applicable):

OSPd-7.3

How reproducible:

From a functionnal 7.1, I tried to upgrade the undercloud. After the update, the new grub.cfg file did not contain initrd16 entry, so the system can boot without regerating a config file with "grub2-mkconfig -o /boot/grub2/grub.cfg".

After fixing this issue on the undercloud, I did the upgrade for the overcloud, same issue with the all overcloud nodes


Steps to Reproduce:
Undercloud:
1. upgrade from 7.1 to 7.3 the undercloud with yum update
2. reboot the undercloud

Overcloud:
1. upgrade via "openstack overcloud update stack"
2. reboot a node

Actual results:

Nodes crash during the boot process

Expected results:

Nodes up and running

Additional info:
Comment 2 Nicolas Hicher 2016-03-15 11:30:59 EDT
Not able to reproduce, I can find what was the problem

Note You need to log in before you can comment on or make changes to this bug.