Bug 1311747 - Packages that depend on pulp-selinux do not Require that package
Packages that depend on pulp-selinux do not Require that package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulp (Show other bugs)
24
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Randy Barlow
Fedora Extras Quality Assurance
https://pulp.plan.io/issues/1712
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-24 16:15 EST by Randy Barlow
Modified: 2016-03-03 17:03 EST (History)
4 users (show)

See Also:
Fixed In Version: pulp-2.8.0-0.7.beta.1.fc24, pulp-2.8.0-0.7.beta.1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 17:03:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2016-02-24 16:15:08 EST
Description of problem:
There are at least two packages that depend on pulp-selinux to be installed for correct operation: pulp-server and python-pulp-streamer. Neither of these two examples Require pulp-selinux and so if they are installed in Fedora they will not operate correctly until the user installs pulp-selinux.

We need to identify if any of our other packages also need pulp-selinux and then add the appropriate Requires lines to our spec file.

There is an upstream issue about the upstream spec file as well, so pay attention to whatever other dependencies are discovered there:

https://pulp.plan.io/issues/1712

Note You need to log in before you can comment on or make changes to this bug.