Bug 131175 - mga driver crashes with openGL clients when DRI is enabled
mga driver crashes with openGL clients when DRI is enabled
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 03:39 EDT by Hans de Goede
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 13:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2004-08-28 03:39:26 EDT
I'm running the Fedora Core 3 test release updated with the latest
package from the Fedora Development branch. This version of Fedora
contains the latest CVs version of the xorg xservers. (6.7.99.902) .

I first discovered this problem when running a program I was doing
some hacking on which uses openGL (x.mame.net) . Because I was working
on this program I was linking it with ElectricFence (malloc debugger)
to catch any bufferoverruns.

Now if I leave DRI enabled and run any application with Electricfence
linked in, it segfaults. Try for example:
export LD_PRELOAD=libefence.so.0.0
cd Mesa-6.0.1/progs/demos/
./tunnel

I can produce a backtrace in gdb if you want. I've tried upgrading to
the latest CVS drm but that doesn't help.
Comment 1 Hans de Goede 2004-08-28 03:40:02 EDT
Also submitted upstream:
http://freedesktop.org/bugzilla/show_bug.cgi?id=1217
Comment 2 Mike A. Harris 2004-09-01 13:22:13 EDT
Changing to "devel" version, there is no "test3" out.

Adding myself to CC on upstream bug report.  Thanks for reporting
issue.

Setting status to "UPSTREAM" for tracking in upstream bugzilla.

Note You need to log in before you can comment on or make changes to this bug.