Bug 1311835 - [virtio-win][svvp][ws2016] job "Driver Firmware Configuration Test" failed during ws2016 svvp test
[virtio-win][svvp][ws2016] job "Driver Firmware Configuration Test" failed du...
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2016-02-25 02:16 EST by lijin
Modified: 2016-08-15 04:10 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-08-15 04:10:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description lijin 2016-02-25 02:16:10 EST
Created attachment 1130430 [details]
"Driver Firmware Configuration Test" hlk log

Description of problem:
win2016 svvp job "Driver Firmware Configuration Test" failed.

Version-Release number of selected component (if applicable):
    Guest : windows server 2016 technical preview 4
    HLK version:10.1.10586.0
    HLK playlist version:1.9

How reproducible:

Steps to Reproduce:
1.boot win2016 guest with:
/usr/libexec/qemu-kvm --nodefaults --nodefconfig -m 8G -smp 8 -boot menu=on -cpu Nehalem,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic,hv_time -machine pc,iommu=on -uuid 48907ee3-35c8-424f-b9d5-3ca16a277b09 -smbios type=1,manufacturer=Red Hat,product=Red Hat Enterprise OpenStack and Red Hat Enterprise Linux with Enterprise Virtualization,version=7Server-0.1,serial=44454C4C-5700-1058-804B-B7 C04 F483258_00:21:9b:58:d2:90,uuid=c00ad584-a5b0-4a69-bbd3-5549ba234079 -usb -device usb-tablet,id=tablet0 -object iothread,id=thread0 -drive file=win2016-SUT-new.qcow2,if=none,id=drive-virtio0-0-0,format=qcow2,werror=stop,rerror=stop,cache=none,serial=number -device virtio-blk-pci,iothread=thread0,drive=drive-virtio0-0-0,id=virti0-0-0,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup1,queues=4 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:e2:52:4e:02:99,addr=0x04,mq=on,vectors=10 -name win2016R2-SUT -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1 -device usb-ehci,id=ehci0 -drive file=usb-storage-intel-max.raw,if=none,id=drive-usb-2-0,media=disk,format=raw,cache=none,werror=stop,rerror=stop,aio=threads -device usb-storage,bus=ehci0.0,drive=drive-usb-2-0,id=usb-2-0,removable=on -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=b111a,path=/tmp/monitor-win2016-sut,server,nowait -mon chardev=b111a,mode=readline -monitor stdio -vnc :10 -vga cirrus

2.submit job in HLK

Actual results:
job failed as following:

System.Exception: Computer hardware id and description counts don't match: ids = 3, descs = 7
   at Microsoft.DFTest.IDP.DeviceInventory.GetComputerHardwareIds()
   at Microsoft.DFTest.IDP.DeviceInventory.CreateDeviceInventory(String xmlOutputFile)
   at Microsoft.DFTest.IDP.DriverFirmwareConfig.PrepareSystem()

[HRESULT: 0x80131604]. Test operation failed: 'PrepareSystem'.

Expected results:
job can pass

Additional info:
Comment 1 lijin 2016-02-29 20:00:36 EST
After remove "-smbios type=1,manufacturer="Red Hat",product="Red Hat Enterprise OpenStack and Red Hat Enterprise Linux with Enterprise Virtualization,version=7Server-0.1",serial="44454C4C-5700-1058-804B-B7 C04 F483258_00:21:9b:58:d2:90",uuid=c00ad584-a5b0-4a69-bbd3-5549ba234079",this job can pass sub-job "PrepareSystem".

But job still failed at sub-job "Check BitLocker is on",error message:"Please turn on BitLocker and re-run the test."

I tried on a physical windows OS with TPM hardaware,I can Turn on BitLocker;
I tried to passthrough the TPM hardware to guest,it shows "qemu-kvm: -tpmdev: invalid option" when boot guest with "-tpmdev passthrough,id=tpm0 -device tpm-tis,tpmdev=tpm0",seems qemu does not support it.

I will attach the latest hlk logs later.
Comment 4 lijin 2016-08-14 23:21:57 EDT
this job can be excluded after using the latest playlist
Comment 5 Yan Vugenfirer 2016-08-15 04:10:24 EDT
(In reply to lijin from comment #4)
> this job can be excluded after using the latest playlist

Great! Closing the BZ.

Note You need to log in before you can comment on or make changes to this bug.