Bug 131186 - GNAT Enumeration probelem in case statement: Assert_Failure namet.adb:517
GNAT Enumeration probelem in case statement: Assert_Failure namet.adb:517
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-28 12:32 EDT by Hans Ulrich Niedermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 03:30:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ada source file triggering the GNAT bug (321 bytes, text/plain)
2004-08-28 12:33 EDT, Hans Ulrich Niedermann
no flags Details
Self-contained Ada source file triggering the GNAT bug (357 bytes, text/plain)
2004-08-28 12:49 EDT, Hans Ulrich Niedermann
no flags Details

  None (edit)
Description Hans Ulrich Niedermann 2004-08-28 12:32:11 EDT
Description of problem:

Internal GNAT error gets triggered by source file.

Version-Release number of selected component (if applicable):

gcc-gnat-3.3.3-7

How reproducible:

Every time.

Steps to Reproduce:
1. gnatmake -c bugtest.adb
  
Actual results:

gcc -c bugtest.adb
+===========================GNAT BUG
DETECTED==============================+
| 3.3.3 20040412 (Red Hat Linux 3.3.3-7) (i386-redhat-linux-gnu)     
     |
| Assert_Failure namet.adb:517                                       
     |
| Error detected at bugtest.adb:14:18                                
     |
| Please submit a bug report; see http://gcc.gnu.org/bugs.html.      
     |
| Include the entire contents of this bug box in the report.         
     |
| Include the exact gcc or gnatmake command that you entered.        
     |
| Also include sources listed below in gnatchop format               
     |
| concatenated together with no headers between files.               
     |
+==========================================================================+

Please include these source files with error report

bugtest.adb
list may be incomplete
compilation abandoned
gnatmake: "bugtest.adb" compilation error

Expected results:

Either compile to .o and .ali files, or stop with an error message.

Additional info:

Seems to be a longstanding bug, already present in GNAT 3.15p:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14386

As I don't know whether FC2 uses a "FSF release" or not, I suppose it
is better to report it here first.
Comment 1 Hans Ulrich Niedermann 2004-08-28 12:33:51 EDT
Created attachment 103206 [details]
Ada source file triggering the GNAT bug
Comment 2 Hans Ulrich Niedermann 2004-08-28 12:49:53 EDT
Created attachment 103208 [details]
Self-contained Ada source file triggering the GNAT bug
Comment 3 Jakub Jelinek 2004-10-08 03:30:26 EDT
Current rawhide GNAT stops with error message:

rpm -q gcc-gnat; gnatmake -c bugtest2.adb
gcc-gnat-3.4.2-5
gcc -c bugtest2.adb
bugtest2.adb:11:07: missing case values: "Foo" .. "Bar"
bugtest2.adb:12:15: "Undefined_Enum_Value" is undefined
gnatmake: "bugtest2.adb" compilation error

Note You need to log in before you can comment on or make changes to this bug.