Bug 1311999 - [RFE] Director should rebalance data & remove node from ceph cluster when 'openstack overcloud node delete' is called
[RFE] Director should rebalance data & remove node from ceph cluster when 'op...
Status: CLOSED DUPLICATE of bug 1311997
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Angus Thomas
Arik Chernetsky
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 08:19 EST by Jaison Raju
Modified: 2016-02-25 08:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-25 08:48:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaison Raju 2016-02-25 08:19:26 EST
1. Proposed title of this feature request  
      Director should rebalance data & remove node from ceph cluster when 'openstack overcloud node delete' is called

    3. What is the nature and description of the request?  
'openstack overcloud node delete' just kills the node .
In case of a ceph node , it is preferable / expected that the data from the
cluster is rebalanced so that there is no data corruption/missing .

Director needs to perform
'CHAPTER 15. REMOVING OSDS (MANUAL)' from the following doc:
https://access.redhat.com/documentation/en/red-hat-ceph-storage/version-1.3/red-hat-ceph-storage-13-red-hat-ceph-administration-guide/ 

There is proper support for similar operation in the puppet module but we don't have the overstructure in the templates to run the action before deletion yet.
Comment 2 Mike Burns 2016-02-25 08:48:16 EST

*** This bug has been marked as a duplicate of bug 1311997 ***

Note You need to log in before you can comment on or make changes to this bug.