Bug 1312016 - Yum dependency issue, openscap.i686 is unavailable in Satellite Tools 6.1 repo
Yum dependency issue, openscap.i686 is unavailable in Satellite Tools 6.1 repo
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin (Show other bugs)
6.1.6
All Linux
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 09:21 EST by jalviso
Modified: 2016-10-03 02:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 02:50:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openscap install error (15.70 KB, text/plain)
2016-02-25 09:22 EST, jalviso
no flags Details

  None (edit)
Description jalviso 2016-02-25 09:21:43 EST
Description of problem:

When installing a package to a Content Host that has openscap as dependency, it installs x86_64 from RHEL6 rpms repo (latest "openscap-1.0.10-3.el6") but when .i686 is installed, it looks for "openscap-1.2.4-1.el6_6sat.x86_64" available from "Satellite Tools 6.1" repo but fails due to:

Protected multilib versions: openscap-1.2.4-1.el6_6sat.x86_64 != openscap-1.0.10-3.el6.i686

Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Register a RHEL6 Content Host and attach to a Content View that is recently
   synced with and update:
   rhel-6-server-rpms
   rhel-6-server-satellite-tools-6.1-rpms
2. Install i386/i686 rpms (example, some third party monitoring rpm's)
3. Install a package that has openscap as dependent package:
  
 # yum install preupgrade-assistant

Actual results:

Protected multilib versions: openscap-1.2.4-1.el6_6sat.x86_64 != openscap-1.0.10-3.el6.i686

a. openscap-1.0.8-1 will be installed as dependent package of 
    preupgrade-assistant-2.1.1-5.el6.x86_64
b. Then it upgrades to openscap-1.0.10-3.el6.x86_64 and installs
   openscap-1.0.10-3.el6.i686 (latest version available in RHEL6 RPMS repo)
c. But since a later version is available in Satellite Tools 6.1 repo, it  
   installs it, "openscap-1.2.4-1.el6_6sat.x86_64" but no matching .i686 version

See complete output attach, "openscap.i386"

Expected results:

It should install "openscap-1.2.4-1.el6_6sat.i686" but there is none available.

Additional info:
Comment 1 jalviso 2016-02-25 09:22 EST
Created attachment 1130558 [details]
openscap install error
Comment 2 Bryan Kearney 2016-07-26 15:03:28 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 3 Marek Hulan 2016-09-12 04:04:19 EDT
It seems that openscap-1.2.8-2.el6 was released during RHEL-6.8 GA (via RHEA-2016:0806) which should now install instead. Could you please check if it's still an issue after upgrade to 6.8?
Comment 5 Marek Hulan 2016-10-03 02:50:12 EDT
we got confirmed that this is no longer an issue

Note You need to log in before you can comment on or make changes to this bug.