Bug 131203 - fstab-sync add all partion in fstab automatically.
fstab-sync add all partion in fstab automatically.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-29 03:05 EDT by sangu
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-29 17:13:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-08-29 03:05:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.7

Description of problem:
booting or installing hal package, fstab-sync works like messages in
/var/log/messages

Aug 29 15:42:47 sangu fstab-sync[4183]: added mount point
/media/idedisk for /dev/hdb9
Aug 29 15:42:48 sangu fstab-sync[4186]: added mount point
/media/idedisk1 for /dev/hdb8
Aug 29 15:42:48 sangu fstab-sync[4192]: added mount point
/media/idedisk2 for /dev/hdb7
Aug 29 15:42:48 sangu fstab-sync[4195]: added mount point
/media/idedisk3 for /dev/hdb6
Aug 29 15:42:48 sangu fstab-sync[4200]: added mount point
/media/idedisk4 for /dev/hdb5
Aug 29 15:42:49 sangu fstab-sync[4208]: added mount point
/media/idedisk5 for /dev/hdb1
Aug 29 15:42:50 sangu fstab-sync[4230]: added mount point
/media/idedisk6 for /dev/hda6
Aug 29 15:42:50 sangu fstab-sync[4234]: added mount point
/media/idedisk7 for /dev/hda5
Aug 29 15:42:51 sangu fstab-sync[4242]: added mount point
/media/idedisk8 for /dev/hda1


$cat /etc/fstab

LABEL=/                 /                       ext3    defaults     
  1 1
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /proc                   proc    defaults     
  0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
none                    /sys                    sysfs   defaults     
  0 0
/dev/hda7               swap                    swap    defaults     
  0 0
/dev/fd0                /mnt/floppy             auto   
noauto,owner,kudzu 0 0
/dev/hdd                /media/dvdrom           auto   
noauto,user,exec,kudzu,ro 0 0
/dev/hdc                /media/cdrw             auto   
noauto,user,exec,kudzu,ro 0 0
/dev/hdb9               /media/idedisk          vfat   
noauto,user,exec,kudzu 0 0
/dev/hdb8               /media/idedisk1         vfat   
noauto,user,exec,kudzu 0 0
/dev/hdb7               /media/idedisk2         vfat   
noauto,user,exec,kudzu 0 0
/dev/hdb6               /media/idedisk3         vfat   
noauto,user,exec,kudzu 0 0
/dev/hdb5               /media/idedisk4         vfat   
noauto,user,exec,kudzu 0 0
/dev/hdb1               /media/idedisk5         vfat   
noauto,user,exec,kudzu 0 0
/dev/hda6               /media/idedisk6         vfat   
noauto,user,exec,kudzu 0 0
/dev/hda5               /media/idedisk7         vfat   
noauto,user,exec,kudzu 0 0
/dev/hda1               /media/idedisk8         ntfs   
noauto,user,exec,kudzu 0 0

/dev/hda1's filesystem is ntfs. 
But fedora official kernel packages don't have ntfs modules. 
So, user can't access /dev/hda1.

Korean name direcory is in the rest partions(those filesystem is vfat).

Added mount option automatically by fstab-sync, user can't acess
korean name diretory. 

Please see also :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=126641


Version-Release number of selected component (if applicable):
hal-0.2.97.cvs20040828-1

How reproducible:
Always

Steps to Reproduce:
1. fstab-sync add all partion in /etc/fstab automatically.
2.
3.
    

Additional info:

LANG=ko_KR.UTF-8
Korea name directorys are encoding to utf8 in vfat partion.
Comment 1 David Zeuthen 2004-08-29 17:13:43 EDT
The ntfs entry is not a bug, it's a feature. 

Presumably fstab-sync could read LANG from /etc/sysconfig/i18n and use
that when adding the entries but that requires some upstream
discussion. There may be a better way to solve this, not sure.

You can always just remove the 'kudzu' option and add your own
options; then fstab-sync won't add new entries nor delete your edited
entries.

Another option is to specify the default NLS in the kernel; these
links also provide more information about that

http://linus.bkbits.net:8080/linux-2.5/user=hirofumi/cset@1.1803.60.1?nav=!-|index.html|stats|!+|index.html|ChangeSet@-4w
http://linus.bkbits.net:8080/linux-2.5/user=torvalds/cset@1.1803.79.18?nav=!-|index.html|stats|!+|index.html|ChangeSet@-4w

Note You need to log in before you can comment on or make changes to this bug.