Bug 1312037 - Configure/Network tab empty if <totem> section is missing from cluster.conf
Configure/Network tab empty if <totem> section is missing from cluster.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Ryan McCabe
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 10:18 EST by Radek Steiger
Modified: 2016-08-17 11:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-17 11:47:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Steiger 2016-02-25 10:18:11 EST
> Description of problem:

When <totem> element is missing from cluster.conf the Configure->Network page form is almost empty (with the exception of secauth and TTL). Adding that section in cluster.conf or changing any of the default (which will cause adding the section automatically) makes luci pre-fill all form items with default values.

Removing the <totem> section (or settings defaults everywhere in the luci tab) will hide the default values again.

Looks like luci is only able to show the default when <totem> is present in cluster.conf.


> Version-Release number of selected component (if applicable):

luci-0.26.0-77.el6.x86_64


> Steps to Reproduce:

1) Have a cluster.conf with no <totem> section
2) Open Configure->Network tab in luci
3) Modify any of the form items and submit


> Actual results:

After step 2) the Configure->Network form is almost empty.
After step 3) the Configure->Network is pre-filled with default values


> Expected results:

Default values shown in both step 2) and 3)

Note You need to log in before you can comment on or make changes to this bug.