Bug 1312155 - Unused ManagementNetworkVlanID in controller_v6.yaml
Unused ManagementNetworkVlanID in controller_v6.yaml
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-rdomanager-oscplugin (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
:
: 1331083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 17:14 EST by Francesco Vollero
Modified: 2016-10-10 13:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The controller_v6.yaml template contains a parameter for a Management network VLAN. This parameter is not supported in the current version of the director, and can be safely ignored along with any comments referring to the Management network. The Management network references do not need to be copied to any custom templates. This parameter will be supported in a future version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-10 13:00:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francesco Vollero 2016-02-25 17:14:15 EST
Howdy, 

looking at the Tripleo heat modules of the 7.3, I noticed a new param, the one in subject, ManagementNetworkVlanID, probably a wrong cherry picking of the patches, but since is there, it could bring confusion and in the case of the v6 also distractions and errors.
Comment 2 Dan Sneddon 2016-02-25 17:16:09 EST
(In reply to Francesco Vollero from comment #0)
> Howdy, 
> 
> looking at the Tripleo heat modules of the 7.3, I noticed a new param, the
> one in subject, ManagementNetworkVlanID, probably a wrong cherry picking of
> the patches, but since is there, it could bring confusion and in the case of
> the v6 also distractions and errors.

Having the extra parameter in the NIC config template won't hurt anything, but it will cause confusion. The references to the Management network should be removed, I'll work on a patch.
Comment 3 Dan Sneddon 2016-02-25 17:34:41 EST
(In reply to Dan Sneddon from comment #2)
> (In reply to Francesco Vollero from comment #0)
> > Howdy, 
> > 
> > looking at the Tripleo heat modules of the 7.3, I noticed a new param, the
> > one in subject, ManagementNetworkVlanID, probably a wrong cherry picking of
> > the patches, but since is there, it could bring confusion and in the case of
> > the v6 also distractions and errors.
> 
> Having the extra parameter in the NIC config template won't hurt anything,
> but it will cause confusion. The references to the Management network should
> be removed, I'll work on a patch.

Note that the patch will probably not be merged into OSP-Director 7. We'll pick up the changes in stable/liberty for OSP 8.
Comment 4 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Dan Yocum 2016-04-27 12:55:34 EDT
*** Bug 1331083 has been marked as a duplicate of this bug. ***
Comment 7 Dan Yocum 2016-04-27 12:57:45 EDT

When using the network-environment.yaml file to deploy the overcloud, the nic-configs say to "uncomment this section if using the network-environment.yaml file," assuming that this is set correctly in the network-environment.yaml file. 

This parameter does not even exist in the network-environment.yaml file.

This causes the default vlan, with ID 60, to be created which may or may not be supported on the switch.

Version-Release number of selected component (if applicable):

openstack-tripleo-heat-templates-0.8.14-7.el7ost.noarch
Comment 8 Dan Yocum 2016-04-27 12:58:41 EDT
And, I should note, this is in *all* nic-config template files.
Comment 9 Dan Sneddon 2016-10-10 12:59:33 EDT
(In reply to Dan Yocum from comment #7)
> 
> When using the network-environment.yaml file to deploy the overcloud, the
> nic-configs say to "uncomment this section if using the
> network-environment.yaml file," assuming that this is set correctly in the
> network-environment.yaml file. 
> 
> This parameter does not even exist in the network-environment.yaml file.
> 
> This causes the default vlan, with ID 60, to be created which may or may not
> be supported on the switch.
> 
> Version-Release number of selected component (if applicable):
> 
> openstack-tripleo-heat-templates-0.8.14-7.el7ost.noarch

Dan, the behavior you describe is not how the os-net-config templates work. If there is no interface which is configured to use the Management network (and this is commented out by default), then no Management interface will be created on the hosts. So in that case, the Management network VLAN wouldn't appear anywhere.
Comment 10 Dan Sneddon 2016-10-10 13:00:55 EDT
(In reply to Francesco Vollero from comment #0)
> Howdy, 
> 
> looking at the Tripleo heat modules of the 7.3, I noticed a new param, the
> one in subject, ManagementNetworkVlanID, probably a wrong cherry picking of
> the patches, but since is there, it could bring confusion and in the case of
> the v6 also distractions and errors.

It was a rebasing error that caused the Management network parameter to be included in OSP 7.3, but that parameter is actually used in OSP 8 and later. The parameter is not used by default, it is declared in every network resource file, and then only used if the Management network is configured by the installer (it is disabled by default).

Note You need to log in before you can comment on or make changes to this bug.