Bug 1312160 - [DOCS] Specifications for external load balancer for Native HA Environment [NEEDINFO]
[DOCS] Specifications for external load balancer for Native HA Environment
Status: CLOSED DUPLICATE of bug 1439231
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michael Burke
zhaozhanqi
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-25 17:34 EST by Ryan Howe
Modified: 2018-06-11 13:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-11 13:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mburke: needinfo? (rhowe)


Attachments (Terms of Use)

  None (edit)
Comment 1 Ryan Howe 2017-07-03 11:03:35 EDT
Document URL: https://docs.openshift.com/container-platform/3.5/install_config/install/advanced_install.html#multiple-masters

Describe the issue: 

The documentation needs to expand on requirements for using a custom LB for the master infrastructure. 

The docs currently link to a upstream document: 
https://github.com/redhat-cop/openshift-playbooks/blob/master/playbooks/installation/load_balancing.adoc#load-balancing-for-ha-master-infrastructure


We need to have this in the official OpenShift documentation. 

NEEDS:
  - Information on how to handle SSL/TLS traffic 
  - SSL termination vs SSL passthrough configuration information. SSL termination should  not be used for internal OpenShift component communication to the masterURL. 
  - Acceptable timeouts for different connections. 
  - Information regarding configuration / support for tunnel connections (websocket or SPDY )
Comment 4 Michael Burke 2018-06-04 13:51:45 EDT
Ryan --

Can you take a look at what we have in the docs now? 

https://docs.openshift.com/container-platform/3.9/install_config/certificate_customization.html#configuring-custom-certificates-lb

I worked with the same source information as you suggested using via https://bugzilla.redhat.com/show_bug.cgi?id=1439231#c5 

Did Paul Dwyer request the additional material as you are asking for? Or, do we need to add some more from that source?

Michael
Comment 5 Michael Burke 2018-06-11 13:33:12 EDT
Per Ryan Howe via IRC, this is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1439231. Closing.

*** This bug has been marked as a duplicate of bug 1439231 ***
Comment 6 Michael Burke 2018-06-11 13:33:34 EDT
Per Ryan Howe via IRC, this is a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1439231. Closing.

Note You need to log in before you can comment on or make changes to this bug.