Bug 131224 - kernel caching the non-existence of nfs file
Summary: kernel caching the non-existence of nfs file
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-30 06:08 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 02:39:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2004-08-30 06:08:27 UTC
Description of problem:
To save bandwidth I usually don't mirror a complete tree
but exclude packages that I don't think I'll need.  However
sometimes dependencies change and new packages or subpackages
are added, and then anaconda may complain that a certain
required package is missing.  However while adding the missing
package and clicking the dialog used to work, this currently
doesn't seem to be the case.

Version-Release number of selected component (if applicable):
anaconda-10.0.2-0.20040826115153

How reproducible:
almost every time

Steps to Reproduce:
1. Remove some required package from tree on nfs mount
2. Start up nfs install.
3. Wait for missing package dialog to appear.
4. Restore missing package.
5. Click on dialog.
  
Actual results:
Dialog reappears although missing package is there.

Expected results:
Missing package seen and installed.

Additional info:
Not quite sure when this started happening since it is a while
since I did a fresh nfs install.

Comment 1 Jeremy Katz 2004-08-30 15:34:47 UTC
This is the kernel caching the non-existence of the file, not me

Comment 2 Steve Dickson 2005-10-31 21:18:57 UTC
Is this still happpening with later releases?

Comment 3 Jens Petersen 2005-11-01 07:10:11 UTC
Currently anaconda is using yum for network installs and backtraces
when a package is missing: so it is harder to test this now.

(I filed bug 172182 in connection with that.)

Comment 4 Steve Dickson 2005-11-01 11:20:17 UTC
So can I call this bug a duplicate of bug 172182?

Comment 5 Jens Petersen 2005-11-04 06:25:32 UTC
Not really - that is purely an anaconda bug.

Comment 6 Steve Dickson 2006-01-03 19:25:57 UTC
 Reassigning per Comment #5

Comment 7 Jens Petersen 2006-01-04 10:10:49 UTC
Erm, bug 172182 is an anaconda bug and this is certainly a kernel nfs bug
afaiu, so should it really be re-assigned back to anaconda?

Comment 8 Jeremy Katz 2006-01-06 02:39:48 UTC
This should be fixed based on some other things that I've tested recently (it is
the kernel side bug, though)


Note You need to log in before you can comment on or make changes to this bug.