Bug 1312347 - IPv6 broken due to urllib3 duplicating brackets in request header
IPv6 broken due to urllib3 duplicating brackets in request header
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-urllib3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ralph Bean
Fedora Extras Quality Assurance
:
Depends On: 1312070
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 09:02 EST by Alan Pevec
Modified: 2016-03-09 15:12 EST (History)
5 users (show)

See Also:
Fixed In Version: python-urllib3-1.13.1-3.fc23 python-urllib3-1.13.1-3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1312070
Environment:
Last Closed: 2016-03-01 20:51:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Pevec 2016-02-26 09:02:58 EST
+++ This bug was initially created as a clone of Bug #1312070 +++

Description of problem:
During ipv6 deploy puppet fails with error:
 Error: Could not prefetch keystone_role provider 'openstack': Execution of '/usr/bin/openstack role list --quiet --format csv' returned 1: Bad Request (HTTP 400)

This is caused by python-urllib3 setting Host header to [[ipv6addr]]. The issue is fixed in upstream https://github.com/shazow/urllib3/pull/801

--- Additional comment from Alan Pevec on 2016-02-25 16:49:45 EST ---

Broken is python-urllib3-1.13.1-2.el7 which is rebuild of latest Fedora version.
We need it b/c it goes together with latest python-requests, required by openstack/global-reqs.
Comment 1 Alan Pevec 2016-02-26 09:06:58 EST
This patch fixed the issue for Lukas:

https://patch-diff.githubusercontent.com/raw/shazow/urllib3/pull/801.patch
Comment 2 Fedora Update System 2016-02-26 14:58:27 EST
python-urllib3-1.13.1-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bab9431ffb
Comment 3 Fedora Update System 2016-02-26 14:58:43 EST
python-urllib3-1.13.1-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a4bd1bc58
Comment 4 Fedora Update System 2016-02-28 08:53:43 EST
python-urllib3-1.13.1-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5a4bd1bc58
Comment 5 Fedora Update System 2016-02-28 08:55:50 EST
python-urllib3-1.13.1-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bab9431ffb
Comment 6 Fedora Update System 2016-03-01 20:50:58 EST
python-urllib3-1.13.1-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2016-03-09 11:22:20 EST
python-urllib3-1.13.1-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2016-03-09 15:12:13 EST
python-urllib3-1.13.1-3.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.