Bug 1312356 - [old-versions:deploy] overcloud is CREATE_COMPLETE but deployment fails due to inaccessible OS_AUTH_URL
[old-versions:deploy] overcloud is CREATE_COMPLETE but deployment fails due t...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Dan Yasny
: Automation, AutomationBlocker
: 1312355 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 09:19 EST by Adriano Petrich
Modified: 2016-03-09 03:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-08 11:13:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adriano Petrich 2016-02-26 09:19:02 EST
Description of problem:
Doing a mixed versions deploy overcloud deploy fails but inspecting the installation the overcloud was created and the overcloudrc was written

Version-Release number of selected component (if applicable):
Undercloud installed with osp8 overcloud image created on osp7

How reproducible:
Very

Steps to Reproduce:
1. install the undercloud on osp8
2. get and add the osp7 overcloud image to that installation
3. copy the kilo tht in ~/local_tht
4. openstack overcloud deploy --debug --log-file overcloud_deployment_21.log --templates /home/stack/local_tht/ --libvirt-type=qemu --ntp-server 10.5.26.10 --control-scale 1 --compute-scale 1 --ceph-storage-scale 1 --block-storage-scale 0 --swift-storage-scale 0 --control-flavor baremetal --compute-flavor baremetal --ceph-storage-flavor baremetal --block-storage-flavor baremetal --swift-storage-flavor baremetal --neutron-network-type vxlan --neutron-tunnel-types vxlan --timeout=90 -e /home/stack/local_tht/environments/network-isolation.yaml -e /home/stack/local_tht/environments/net-single-nic-with-vlans.yaml -e ~/network-environment.yaml -e /home/stack/local_tht/environments/storage-environment.yaml -e ~/default-overcloud-settings.yaml

Actual results:
deploy fails

Expected results:
deploy works

Additional info:
Log result:

reating endpoint for service 5f8a3aa143f94ff5aeb3b34848cf5ba4.
REQ: curl -g -i -X POST http://192.0.2.14:35357/v2.0/endpoints -H "User-Agent: python-keystoneclient" -H "Content-Type: application/json" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}92b3e0685476c0746258fbaade4e3ca7d8563d4b" -d '{"endpoint": {"adminurl": "http://192.0.2.14:35357/v2.0", "service_id": "5f8a3aa143f94ff5aeb3b34848cf5ba4", "region": "regionOne", "internalurl": "http://172.16.20.11:5000/v2.0", "publicurl": "http://172.16.23.110:5000/v2.0"}}'
RESP: [200] content-length: 268 vary: X-Auth-Token connection: keep-alive date: Fri, 26 Feb 2016 10:09:11 GMT content-type: application/json x-openstack-request-id: req-f67116f6-e6f8-409d-947c-5970d1855379 
RESP BODY: {"endpoint": {"adminurl": "http://192.0.2.14:35357/v2.0", "region": "regionOne", "internalurl": "http://172.16.20.11:5000/v2.0", "service_id": "5f8a3aa143f94ff5aeb3b34848cf5ba4", "id": "b4c79f86a48d4acd9f1673494d6086b1", "publicurl": "http://172.16.23.110:5000/v2.0"}}

PKI initialization in init-keystone is deprecated and will be removed.
Warning: Permanently added '192.0.2.14' (ECDSA) to the list of known hosts.
The following cert files already exist, use --rebuild to remove the existing files before regenerating:
/etc/keystone/ssl/certs/ca.pem already exists
/etc/keystone/ssl/private/signing_key.pem already exists
/etc/keystone/ssl/certs/signing_cert.pem already exists
Connection to 192.0.2.14 closed.
Creating keystone client.
Making authentication request to http://172.16.23.110:5000/v2.0/tokens
Authorization Failed: Unable to establish connection to http://172.16.23.110:5000/v2.0/tokens
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 374, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 54, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 893, in take_action
    self._deploy_postconfig(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 485, in _deploy_postconfig
    overcloud_endpoint)
  File "/usr/lib/python2.7/site-packages/os_cloud_config/utils/clients.py", line 67, in get_keystone_client
    return ksclient.Client(**kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 166, in __init__
    self.authenticate()
  File "/usr/lib/python2.7/site-packages/keystoneclient/utils.py", line 337, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/httpclient.py", line 589, in authenticate
    resp = self.get_raw_token_from_identity_service(**kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 210, in get_raw_token_from_identity_service
    _("Authorization Failed: %s") % e)
AuthorizationFailure: Authorization Failed: Unable to establish connection to http://172.16.23.110:5000/v2.0/tokens
clean_up DeployOvercloud: Authorization Failed: Unable to establish connection to http://172.16.23.110:5000/v2.0/tokens
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/openstackclient/shell.py", line 112, in run
    ret_val = super(OpenStackShell, self).run(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 255, in run
    result = self.run_subcommand(remainder)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 374, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 54, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 893, in take_action
    self._deploy_postconfig(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 485, in _deploy_postconfig
    overcloud_endpoint)
  File "/usr/lib/python2.7/site-packages/os_cloud_config/utils/clients.py", line 67, in get_keystone_client
    return ksclient.Client(**kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 166, in __init__
    self.authenticate()
  File "/usr/lib/python2.7/site-packages/keystoneclient/utils.py", line 337, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/httpclient.py", line 589, in authenticate
    resp = self.get_raw_token_from_identity_service(**kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneclient/v2_0/client.py", line 210, in get_raw_token_from_identity_service
    _("Authorization Failed: %s") % e)
AuthorizationFailure: Authorization Failed: Unable to establish connection to http://172.16.23.110:5000/v2.0/tokens

END return value: 1

#checking is it there
[stack@instack ~]$ curl http://172.16.23.110:5000/v2.0/tokens
curl: (7) Failed connect to 172.16.23.110:5000; Connection timed out


[stack@instack ~]$ cat overcloudrc 
export OS_NO_CACHE=True
export COMPUTE_API_VERSION=1.1
export OS_USERNAME=admin
export no_proxy=,172.16.23.110
export OS_TENANT_NAME=admin
export OS_CLOUDNAME=overcloud
export OS_AUTH_URL=http://172.16.23.110:5000/v2.0
export NOVA_VERSION=1.1
export OS_PASSWORD=9vy3ykVJVWFny6hUATHZuENjM
[stack@instack ~]$ cat stackrc 
export NOVA_VERSION=1.1
export OS_PASSWORD=$(sudo hiera admin_password)
export OS_AUTH_URL=http://192.0.2.1:5000/v2.0
export OS_USERNAME=admin
export OS_TENANT_NAME=admin
export COMPUTE_API_VERSION=1.1
export OS_NO_CACHE=True
export OS_CLOUDNAME=undercloud
export OS_IMAGE_API_VERSION=1
Comment 2 Mike Burns 2016-02-26 09:24:03 EST
*** Bug 1312355 has been marked as a duplicate of this bug. ***
Comment 3 Brad P. Crochet 2016-03-08 11:13:21 EST
Must use a virtual nic for undercloud when using netiso and vlans.

Note You need to log in before you can comment on or make changes to this bug.