Bug 131244 - rmmod ohci1394 hangs, [knodemgrd_0] suspect, requires reboot
rmmod ohci1394 hangs, [knodemgrd_0] suspect, requires reboot
Status: CLOSED DUPLICATE of bug 131243
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 09:09 EDT by Marty Vona
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:05:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marty Vona 2004-08-30 09:09:49 EDT
Description of problem:

After a few hotplug events the ohci1394 module hangs hard.  rmmod
ohci1394 also hangs and won't respond to kill -KILL, so I can't even
re-load the module.

If I do a ps -F -u root at this time I see a [knodemgr_0] thread near
the rmmod process.  That thread will similarly not die.

It looks like the knodemgr thread that the 1394 module sets up is
hanging, and since it has called daemonize() it's not responding to
signals.

In order to get 1394 working again I have to reboot.

This problem has forced me to revert back to a 2.4 kernel under FC2.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:


Steps to Reproduce:
1. do some 1394 hotplugging
2. do some rmmod sbp2 ohci1394 ieee1394; modprobe sbp2
3. eventually the rmmod will hang and 1394 will be borked till reboot
  
Actual results:


Expected results:


Additional info:

There was some discussion of a similar issue on lkml in May 04:

http://www.ussg.iu.edu/hypermail/linux/kernel/0405.0/0520.html
http://www.ussg.iu.edu/hypermail/linux/kernel/0405.0/0525.html

However the 2.6.8-1.521 seems to include the fix reported there but
STILL shows the bug.
Comment 1 Dave Jones 2004-11-27 17:05:10 EST

*** This bug has been marked as a duplicate of 131243 ***

Note You need to log in before you can comment on or make changes to this bug.