This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 131245 - [PATCH] rstatd using /proc/stat
[PATCH] rstatd using /proc/stat
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rusers (Show other bugs)
2.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks: 123573
  Show dependency treegraph
 
Reported: 2004-08-30 09:30 EDT by Tom "spot" Callaway
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 16:23:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
use /proc/partitions, not /proc/stat (4.32 KB, patch)
2004-08-30 09:31 EDT, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Tom "spot" Callaway 2004-08-30 09:30:18 EDT
In RHEL 2.1 & 3, rstatd is currently using /proc/stat to gather disk
usage data. Since /proc/partitions is the "correct" mechanism for RHEL
2.4 kernels to be using, I've written a patch to fix this bug.

This is related to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123136
Comment 1 Tom "spot" Callaway 2004-08-30 09:31:12 EDT
Created attachment 103247 [details]
use /proc/partitions, not /proc/stat
Comment 3 Robert Perkins 2004-09-08 13:17:51 EDT
Note this should be cloned for RHEL3 U4.
Comment 4 Suzanne Hillman 2004-09-10 13:53:54 EDT
Cloned for RHEL3 as bug #132293. Assigning back to pknirsch, as it
should never have been assigned to Jeff Needle. Putting into the U6
MUSTFIX list.
Comment 5 Phil Knirsch 2004-09-13 11:57:38 EDT
Packages built in dist-2.1AS-U6.

Will set to modified when i have done the opened and written the erratas.

Read ya, Phil
Comment 6 Phil Knirsch 2004-09-20 08:28:00 EDT
OK, errata ready.

Setting to modified.

Read ya, Phil
Comment 7 John Flanagan 2004-12-13 16:23:34 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-476.html

Note You need to log in before you can comment on or make changes to this bug.