Bug 1312484 - SELinux is preventing /usr/bin/loginctl from 'read' accesses on the file /var/log/journal/2b6e810f801e4f458fa97f9a3b9c8a3e/system@d1ef87a892124a13921edb97a8939e29-000000000026ba74-00052163a8c78ed8.journal.
SELinux is preventing /usr/bin/loginctl from 'read' accesses on the file /var...
Status: CLOSED DUPLICATE of bug 1295225
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d34c86e148daa79e60c040f3833...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 15:35 EST by MPNC
Modified: 2016-02-29 04:59 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 04:59:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: abrtloginctl022616.jpg (89.65 KB, application/octet-stream)
2016-02-26 15:35 EST, MPNC
no flags Details

  None (edit)
Description MPNC 2016-02-26 15:35:33 EST
Description of problem:
SELinux is preventing /usr/bin/loginctl from 'read' accesses on the file /var/log/journal/2b6e810f801e4f458fa97f9a3b9c8a3e/system@d1ef87a892124a13921edb97a8939e29-000000000026ba74-00052163a8c78ed8.journal.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that loginctl should be allowed read access on the system@d1ef87a892124a13921edb97a8939e29-000000000026ba74-00052163a8c78ed8.journal file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep loginctl /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:apmd_t:s0
Target Context                system_u:object_r:var_log_t:s0
Target Objects                /var/log/journal/2b6e810f801e4f458fa97f9a3b9c8a3e/
                              system@d1ef87a892124a13921edb97a8939e29-0000000000
                              26ba74-00052163a8c78ed8.journal [ file ]
Source                        loginctl
Source Path                   /usr/bin/loginctl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.3.5-300.fc23.i686 #1 SMP Mon Feb
                              1 03:53:33 UTC 2016 i686 i686
Alert Count                   257
First Seen                    2016-01-03 01:30:23 EST
Last Seen                     2016-02-26 13:03:29 EST
Local ID                      194d9a4d-2b24-4237-b2d3-ebfdca35ed15

Raw Audit Messages
type=AVC msg=audit(1456509809.289:332): avc:  denied  { read } for  pid=3352 comm="loginctl" name="system@d1ef87a892124a13921edb97a8939e29-000000000026ba74-00052163a8c78ed8.journal" dev="sda11" ino=264280 scontext=system_u:system_r:apmd_t:s0 tcontext=system_u:object_r:var_log_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1456509809.289:332): arch=i386 syscall=open success=no exit=EACCES a0=81e112f0 a1=88000 a2=0 a3=81e0ffe0 items=0 ppid=3345 pid=3352 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=loginctl exe=/usr/bin/loginctl subj=system_u:system_r:apmd_t:s0 key=(null)

Hash: loginctl,apmd_t,var_log_t,file,read


Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.3.5-300.fc23.i686
type:           libreport

Potential duplicate: bug 1226159
Comment 1 MPNC 2016-02-26 15:35:38 EST
Created attachment 1130900 [details]
File: abrtloginctl022616.jpg
Comment 2 Lukas Vrabec 2016-02-29 04:59:25 EST

*** This bug has been marked as a duplicate of bug 1295225 ***

Note You need to log in before you can comment on or make changes to this bug.