Bug 1312510 - Security Groups remain even after deleting provider
Security Groups remain even after deleting provider
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
All All
low Severity high
: GA
: cfme-future
Assigned To: Tzu-Mainn Chen
Niyaz Akhtar Ansari
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-26 18:37 EST by Kevin Morey
Modified: 2017-08-21 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Openstack


Attachments (Terms of Use)
sec group screenshot after provider has been removed (395.16 KB, image/png)
2016-02-26 18:37 EST, Kevin Morey
no flags Details

  None (edit)
Description Kevin Morey 2016-02-26 18:37:00 EST
Created attachment 1130916 [details]
sec group screenshot after provider has been removed

Description of problem:
I had an OSP 7 provider in the customers lab. Due to other issues the customer deleted the provider. Then after looking in Clouds / Security Groups the customer noticed that the sec groups were still there. Flavors, Tenants and AZ's were cleaned up fine.  Please change the behavior to cleanup security groups when a openstack provider is removed since there isnt a relationship to anything at this point.

the reason this matters is because it can throw off reporting.

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
100%

Steps to Reproduce:
1. Add an openstack provider
2. After a full refresh is completed remove the provider

Actual results:
the security groups remain for that provider

Expected results:
security groups should be removed

Additional info:
see attached screenshot
Comment 2 Kevin Morey 2016-02-26 18:48:37 EST
Also, I just realized that there isnt a way to remove these objects from the UI. I had to going into pgsql and delete them manually.
Comment 3 Chris Pelland 2017-08-21 09:08:10 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.
Comment 4 Chris Pelland 2017-08-21 09:10:17 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.