Bug 1312627 - Update tuxguitar package to version 1.3.1
Update tuxguitar package to version 1.3.1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tuxguitar (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 02:25 EST by ycollet
Modified: 2016-03-11 22:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 22:18:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The spec file (7.54 KB, text/plain)
2016-02-28 02:25 EST, ycollet
no flags Details
The starting script (1.62 KB, application/x-shellscript)
2016-02-28 02:25 EST, ycollet
no flags Details
The desktop script (409 bytes, application/x-desktop)
2016-02-28 02:26 EST, ycollet
no flags Details

  None (edit)
Description ycollet 2016-02-28 02:25:11 EST
Created attachment 1131209 [details]
The spec file

TuxGuitar 1.3.1 has been released.
Please update the tuxguitar package.

I have made a spec file to package this version of tuxguitar.
Comment 1 ycollet 2016-02-28 02:25 EST
Created attachment 1131210 [details]
The starting script
Comment 2 ycollet 2016-02-28 02:26 EST
Created attachment 1131211 [details]
The desktop script
Comment 3 Orcan Ogetbil 2016-03-08 20:55:44 EST
Hi,
Thanks for the reminder. This package was updated about a month ago in rawhide and a few weeks ago in F23. Do your scripts provide improvements over the existing scripts?
Comment 4 ycollet 2016-03-09 02:10:45 EST
Maybe the only thing valuable in my script is the maven build command line: I set gcc flags for the fluidsynth, jack and alsa plugin.

mvn clean package -Dnative-modules=true -Dtuxguitar-alsa.jni.cflags="-I/usr/lib/jvm/java/include -I/usr/lib/jvm/java/include/linux -O2 -fPIC" -Dtuxguitar-jack.jni.cflags="-I/usr/lib/jvm/java/include -I/usr/lib/jvm/java/include/linux -O2 -fPIC" -Dtuxguitar-fluidsynth.jni.cflags="-I/usr/lib/jvm/java/include -I/usr/lib/jvm/java/include/linux -O2 -fPIC" -Dtuxguitar-oss.jni.cflags="-I/usr/lib/jvm/java/include -I/usr/lib/jvm/java/include/linux -O2 -fPIC"

Why did you set the audio default plugin to alsa and not pulseaudio ?
Comment 5 Orcan Ogetbil 2016-03-11 22:18:07 EST
Thanks. The build in koji uses Fedora's %optflags, not just for x86_64, but for all supported architectures:
   http://koji.fedoraproject.org/koji/buildinfo?buildID=734618

Despite all the efforts, the pulseaudio is not being taken as a first class citizen by all pro-audio people that I know. Since this package is aimed at audio enthusiasts alsa was made the primary choice. 
Are you subscribed to the fedora-music-list?

Note You need to log in before you can comment on or make changes to this bug.