Bug 1312653 - The tuskar user is still created on the undercloud
The tuskar user is still created on the undercloud
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
low Severity low
: async
: 10.0 (Newton)
Assigned To: RHOS Maint
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-28 07:40 EST by Udi
Modified: 2016-10-14 12:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 12:03:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2016-02-28 07:40:06 EST
Description of problem:
When you run "openstack user list" on the undercloud machine, you see that the tuskar user is still created. No need to create it any more.


Version-Release number of selected component (if applicable):
python-tripleoclient-0.1.1-4.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install the undercloud
2. Run "openstack user list"
Comment 2 Udi 2016-02-29 09:46:12 EST
It was brought to my attention that the tuskar service is also created in the catalog. No need to create endpoints for the tuskar service either (in addition to the user).
Comment 3 Mike Burns 2016-04-07 17:11:06 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Dmitry Tantsur 2016-10-14 12:03:58 EDT
Seems to be fixed in OSP 10:

$ source stackrc 
$ openstack user list
+----------------------------------+------------------+
| ID                               | Name             |
+----------------------------------+------------------+
| 2d37ccbb1946479cba3158ee113a5e73 | admin            |
| c3c626eada124c25b83dd0b71f72a7eb | glance           |
| 4019fa340af94155920bca4b0a14defe | heat             |
| 64dfa67864ae4fbbaf37d599e81e1035 | ironic           |
| 4ab6c43520084c558469e016e43d2cde | ironic-inspector |
| f02d90eefa194f08aa2b553a648e632e | mistral          |
| ab4e7ca815eb48a9b26984aa8bd7ebad | neutron          |
| 9c251d74c15449ab8700fb5740f3b42c | nova             |
| 9f88aba5524d491d86f588d614e391b2 | swift            |
| 6217b6bad5aa41b2848146502ba76db4 | zaqar            |
| 58a6df951e954cd0ae1626e9d8e466e0 | zaqar-websocket  |
+----------------------------------+------------------+

Note You need to log in before you can comment on or make changes to this bug.