Bug 1312910 - Running login shell in 'rhscl/varnish-4-rhel7' container outputs warnings.
Running login shell in 'rhscl/varnish-4-rhel7' container outputs warnings.
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-varnish4-docker (Show other bugs)
rh-varnish4
x86_64 Linux
unspecified Severity unspecified
: alpha
: 2.2
Assigned To: Jan Kaluža
Peter Hostačný
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 08:59 EST by Peter Hostačný
Modified: 2016-07-31 21:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: rh-varnish4-docker-4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 06:20:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Hostačný 2016-02-29 08:59:14 EST
Description of problem:
Running 'bash -l' in 'rhscl/varnish-4-rhel7' yells some warnings:
bash: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8): No such file or directory
bash: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8): No such file or directory
bash: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
bash: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
bash: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory

Running container with 'bash -l' argument cause the same behavior.
$ docker run --rm -ti rhscl/varnish-4-rhel7 bash -l


Version-Release number of selected component (if applicable):
rhscl/varnish-4-rhel7:4-5

How reproducible:
Always


Steps to Reproduce:
1. docker run --rm -ti rhscl/varnish-4-rhel7 bash -l
OR
1. docker run --rm -ti rhscl/varnish-4-rhel7 bash
2. bash -l

Actual results:
Warnings after login shell start.

Expected results:
No warnings on output after start of login shell.

Additional info:
Comment 6 errata-xmlrpc 2016-05-31 06:20:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1162

Note You need to log in before you can comment on or make changes to this bug.