Bug 1313039 - When restarting subscription-manager-gui after installing some products, none of the new products show in the My Installed Products tab
When restarting subscription-manager-gui after installing some products, none...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-29 14:27 EST by Sean Toner
Modified: 2016-03-01 10:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 10:26:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
After adding products, before restart (394.25 KB, image/png)
2016-02-29 14:27 EST, Sean Toner
no flags Details
After restarting subman-gui (170.31 KB, image/png)
2016-02-29 14:29 EST, Sean Toner
no flags Details
Tail of rhsm.log when starting up subman-gui (5.52 KB, text/plain)
2016-03-01 08:07 EST, Sean Toner
no flags Details

  None (edit)
Description Sean Toner 2016-02-29 14:27:47 EST
Created attachment 1131675 [details]
After adding products, before restart

Description of problem:
=======================

In one of our automated tests, we have a setup function which installs some test data including some "fake" products in /etc/pki/product.  When the pem files have been installed, you can see the products show in the My Installed Products tab.

Later in the test, we automatically restart the GUI.  The test fails because once the GUI is restarted, the only product that shows is the one from /etc/pki/product-default.  It does not appear to be picking up any of the products from /etc/pki/product

This can also happen when manually restarting subman-gui.


Version-Release number of selected component (if applicable):
=============================================================


How reproducible:
=================

Sometimes


Steps to Reproduce:
===================
1. Install a new product (no need to create an entitlement for it though)
2. Check to see it shows in My Installed Products tab 
3. Close subman-gui
4. Restart subman-gui
5. Only the /etc/pki/product-default product shows 
   - verify that new installed product is still in /etc/pki/product

Actual results:
===============

After restarting, only the product from /etc/pki/default-product shows in the My Installed Products tab


Expected results:
=================

The My Installed PRoducts tab should show all products


Additional info:
Comment 1 Sean Toner 2016-02-29 14:29 EST
Created attachment 1131676 [details]
After restarting subman-gui
Comment 2 Sean Toner 2016-02-29 14:30:14 EST
After restarting the GUI (as seen in the 2nd attachment), the products are in /etc/pki/product

[root@dhcp129-207 ~]# ls /etc/pki/product
100000000000000_.pem   100000000000003_.pem  100000000000020_.pem  213412341234_.pem  2701_.pem   37060_.pem  37068_.pem  37090_.pem  6050_.pem  88888_.pem   98121_.pem
100000000000001_.pem   100000000000005_.pem  100000000000060_.pem  213412341235_.pem  2702_.pem   37062_.pem  37069_.pem  37091_.pem  6051_.pem  900_.pem
1000000000000023_.pem  100000000000006_.pem  100000000000069_.pem  213412341236_.pem  27060_.pem  37065_.pem  37070_.pem  5050_.pem   801_.pem   908_.pem
100000000000002_.pem   100000000000011_.pem  1_.pem                213412341237_.pem  32060_.pem  37067_.pem  37080_.pem  5051_.pem   806_.pem   917571_.pem
Comment 4 Barnaby Court 2016-02-29 15:26:53 EST
Is this still an issue? jsefler thinks that you resolved it yourself.
Comment 5 Sean Toner 2016-03-01 07:56:31 EST
No, this is still an issue and JC also hit the same problem manually.

Right now, I have a system that shows only one installed product in My Installed Products tab, but there are still many product certs in /etc/pki/product
Comment 6 Sean Toner 2016-03-01 07:58:35 EST
Looks like I forgot to add the version info:

[root@dhcp129-207 ~]# rpm -qa | grep subscription
subscription-manager-1.16.8-3.el6.x86_64
subscription-manager-gui-1.16.8-3.el6.x86_64
subscription-manager-migration-data-2.0.26-1.el6.noarch
subscription-manager-firstboot-1.16.8-3.el6.x86_64
subscription-manager-migration-1.16.8-3.el6.x86_64
Comment 7 Sean Toner 2016-03-01 08:07 EST
Created attachment 1131933 [details]
Tail of rhsm.log when starting up subman-gui
Comment 8 Sean Toner 2016-03-01 10:26:38 EST
It appears that the testware was not cleaning up the rhsm.conf so that it had this:

productCertDir=/tmp/sm-allProductsSubscribableByOneCommonServiceLevel

This is a testware bug, not a subman-gui bug

Note You need to log in before you can comment on or make changes to this bug.