Bug 131308 - firstboot.py module tracebacks
firstboot.py module tracebacks
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
: 131328 (view as bug list)
Depends On: 131314
Blocks: 130007
  Show dependency treegraph
 
Reported: 2004-08-30 16:05 EDT by Elliot Lee
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 23:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliot Lee 2004-08-30 16:05:55 EDT
This one has to be fixed for FC3test2.

In Date & Time:

File "/usr/share/firstboot/modules/date.py", line 60, in setupScreen:
  self.datePage = date_gui.datePage(self.dateBackend)
TypeError: __init__() takes exactly 3 arguments (2 given)

In Activate:
File "/usr/share/rhn/up2date_client/rhnreg.py", line 363, in
getRemainingSubscriptions()
username, passwd, arch, release)
...
File "/usr/lib/python2.3/xmlrpclib.py", line 620, in dump_nil
  raise TypeError, "cannot marshal None unless allow_none is enabled"
TypeError: cannot marshal None unless allow_none is enabled
Comment 1 Adrian Likins 2004-08-31 16:10:57 EDT
*** Bug 131328 has been marked as a duplicate of this bug. ***
Comment 2 Adrian Likins 2004-08-31 16:14:02 EDT
Workaround for the date module issues should land in 1.3.19
but I think I need some changes to s-c-date to really
fix it correctly. see #131314

Comment 3 Jeremy Katz 2004-09-02 13:56:44 EDT
This still seems busted

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 455, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 92, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 71, in setupScreen
    self.datePageVBox = self.datePage.getVBox()
  File "/usr/share/system-config-date/date_gui.py", line 309, in getVBox
    return self.mainVBox
AttributeError: datePage instance has no attribute 'mainVBox'
Comment 4 Adrian Likins 2004-09-02 14:11:24 EDT
hmm, 1.3.20 is supposed to have
a fix for that (doesnt even import date_gui anymore)
Comment 5 Adrian Likins 2004-09-02 14:12:45 EDT
>
>  hmm, 1.3.20 is supposed to have
a fix for that (doesnt even import date_gui anymore)

which I didnt build... building now.

Note You need to log in before you can comment on or make changes to this bug.