Bug 1313167 - SELinux is preventing /var/lib/pcp/pmdas/rpm/pmdarpm from 'search' accesses on the directory /var/lib/rpm.
SELinux is preventing /var/lib/pcp/pmdas/rpm/pmdarpm from 'search' accesses o...
Status: CLOSED DUPLICATE of bug 1358078
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5f5734929870d59f818b9441558...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-01 01:55 EST by Kazuo Moriwaka
Modified: 2016-08-15 12:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-15 12:05:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazuo Moriwaka 2016-03-01 01:55:17 EST
Description of problem:
Install pcp-pmda-rpm and reboot causes this problem.
SELinux is preventing /var/lib/pcp/pmdas/rpm/pmdarpm from 'search' accesses on the directory /var/lib/rpm.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that pmdarpm should be allowed search access on the rpm directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep pmdarpm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:pcp_pmcd_t:s0
Target Context                system_u:object_r:rpm_var_lib_t:s0
Target Objects                /var/lib/rpm [ dir ]
Source                        pmdarpm
Source Path                   /var/lib/pcp/pmdas/rpm/pmdarpm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           pcp-pmda-rpm-3.11.0-1.fc23.x86_64
Target RPM Packages           rpm-4.13.0-0.rc1.11.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-158.7.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.4.2-301.fc23.x86_64 #1 SMP Tue
                              Feb 23 19:00:38 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-03-01 15:51:32 JST
Last Seen                     2016-03-01 15:51:32 JST
Local ID                      4436ea3d-25be-43ba-af3c-82fb253cd157

Raw Audit Messages
type=AVC msg=audit(1456815092.724:73271): avc:  denied  { search } for  pid=31858 comm="pmdarpm" name="rpm" dev="dm-2" ino=402653377 scontext=system_u:system_r:pcp_pmcd_t:s0 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=dir permissive=0


type=SYSCALL msg=audit(1456815092.724:73271): arch=x86_64 syscall=inotify_add_watch success=no exit=EACCES a0=7 a1=5600c47f32a1 a2=8 a3=60 items=0 ppid=31849 pid=31858 auid=4294967295 uid=986 gid=978 euid=986 suid=986 fsuid=986 egid=978 sgid=978 fsgid=978 tty=(none) ses=4294967295 comm=pmdarpm exe=/var/lib/pcp/pmdas/rpm/pmdarpm subj=system_u:system_r:pcp_pmcd_t:s0 key=(null)

Hash: pmdarpm,pcp_pmcd_t,rpm_var_lib_t,dir,search

Version-Release number of selected component:
selinux-policy-3.13.1-158.7.fc23.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.4.2-301.fc23.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2016-08-15 12:05:37 EDT

*** This bug has been marked as a duplicate of bug 1358078 ***

Note You need to log in before you can comment on or make changes to this bug.