This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 131318 - Running iptraf caused kernel oops in kernel-2.6.7-1.494.2.2
Running iptraf caused kernel oops in kernel-2.6.7-1.494.2.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-30 17:34 EDT by Andre
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 17:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Excerpt from /var/log/messages (3.04 KB, text/plain)
2004-10-27 01:05 EDT, Martin Goik
no flags Details

  None (edit)
Description Andre 2004-08-30 17:34:35 EDT
Description of problem:

I was monitoring network traffic with iptraf on eth0 (e100) during
some SNMP traffic and got a kernel oops:

Aug 30 09:00:14 fish kernel: CPU:    0
Aug 30 09:00:14 fish kernel: EIP:    0060:[<0229dabe>]    Not tainted
Aug 30 09:00:14 fish kernel: EFLAGS: 00210202   (2.6.7-1.494.2.2)
Aug 30 09:00:14 fish kernel: EIP is at __dev_get_by_index+0x14/0x2b
Aug 30 09:00:14 fish kernel: eax: 30ae1194   ebx: 18299ef0   ecx:
00000002   edx: 00000000
Aug 30 09:00:14 fish kernel: esi: 00008910   edi: 00008910   ebp:
fef7df00   esp: 18299ee8
Aug 30 09:00:14 fish kernel: ds: 007b   es: 007b   ss: 0068
Aug 30 09:00:14 fish kernel: Process iptraf (pid: 12775,
threadinfo=18299000 task=17af06f0)
Aug 30 09:00:14 fish kernel: Stack: 0229f2a8 00000000 08998800
00000000 00000014 00000001 00000002 00000000
Aug 30 09:00:14 fish kernel:        00000c20 000000e4 31fe75e0
00008910 00008910 fef7df00 0229fb61 fef7df00
Aug 30 09:00:14 fish kernel:        18299f44 231c4fec 00000df4
307a89e0 03320700 0214e5a6 18299f70 00000018
Aug 30 09:00:14 fish kernel: Call Trace:
Aug 30 09:00:14 fish kernel:  [<0229f2a8>] dev_ifname+0x30/0x66
Aug 30 09:00:14 fish kernel:  [<0229fb61>] dev_ioctl+0x8a/0x28a
Aug 30 09:00:14 fish kernel:  [<0214e5a6>] follow_page_pfn+0xec/0xfd
Aug 30 09:00:14 fish kernel:  [<022f4056>] packet_ioctl+0x20c/0x217
Aug 30 09:00:14 fish kernel:  [<02296a77>] sock_ioctl+0x2f4/0x3aa
Aug 30 09:00:14 fish kernel:  [<02297bca>] sys_socketcall+0x118/0x179
Aug 30 09:00:14 fish kernel:  [<0217546e>] sys_ioctl+0x29a/0x33c
Aug 30 09:00:14 fish kernel: Code: 0f 18 02 90 2d 94 01 00 00 39 48 34
74 08 85 d2 89 d0 75 ea

Version-Release number of selected component (if applicable):

kernel-2.6.7-1.494.2.2
iptraf-2.7.0-9

How reproducible:

Once

Additional info:

After the oops iptraf could not monitor eth0 anymore and the machine
hung up during shutdown trying to stop iptables (so I don't really
want to try to reproduce this unless there is additional information
that might be helpful).

Aug 30 09:58:46 fish kernel: e100: Intel(R) PRO/100 Network Driver, 3.0.18
Aug 30 09:58:46 fish kernel: e100: Copyright(c) 1999-2004 Intel
Corporation
Aug 30 09:58:46 fish kernel: PCI: Found IRQ 11 for device 0000:00:0b.0
Aug 30 09:58:46 fish kernel: PCI: Sharing IRQ 11 with 0000:00:08.0
Aug 30 09:58:46 fish kernel: e100: eth0: e100_probe: addr 0xdf104000,
irq 11, MAC addr 00:90:27:66:C6:7C
Aug 30 09:58:46 fish kernel: e100: eth0: e100_watchdog: link up,
100Mbps, full-duplex
Comment 1 Andre 2004-08-30 17:39:22 EDT
Sorry, forgot the first part of the oops:

Aug 30 09:00:14 fish kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000000
Aug 30 09:00:14 fish kernel:  printing eip:
Aug 30 09:00:14 fish kernel: 0229dabe
Aug 30 09:00:14 fish kernel: *pde = 00000000
Aug 30 09:00:14 fish kernel: Oops: 0000 [#1]
Aug 30 09:00:14 fish kernel: Modules linked in: nls_utf8 snd_seq_midi
snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul
snd_seq_oss snd_seq_midi_event snd_seq snd_pcm_oss snd_mixer_oss
snd_emu10k1
 snd_rawmidi snd_pcm snd_timer snd_seq_device snd_ac97_codec
snd_page_alloc snd_util_mem snd_hwdep snd soundcore radeon loop aes
dm_crypt parport_pc lp parport via686a i2c_sensor i2c_isa i2c_core
8139too e100 mii
ipt_REJECT ipt_mac ipt_state iptable_filter ipt_REDIRECT ipt_LOG
ipt_limit iptable_nat ip_conntrack ipt_owner ipt_TOS iptable_mangle
ip_tables ohci1394 ieee1394 st vfat fat dm_mod uhci_hcd sym53c8xx
scsi_transport
_spi sd_mod scsi_mod
Comment 2 Torbjorn Jansson 2004-10-26 15:28:07 EDT
i've managed to get the exact same oops with iptraf but with kernel 
2.6.8-1.521
Comment 3 Martin Goik 2004-10-27 01:05:07 EDT
Created attachment 105823 [details]
Excerpt from /var/log/messages
Comment 4 Dave Jones 2004-11-27 17:31:40 EST
mass update for old bugs:

Is this still a problem in the 2.6.9 based kernel update ?
Comment 5 Torbjorn Jansson 2004-11-27 17:47:33 EST
i've updated to fc3 and the problem is gone in that kernel version (2.6.9-
1.681_FC3)

but updating to fc3 caused a hole bunch of other problems, but that's another 
story.
if i knew what i know now, i woud never have updated to fc3 due to all broken 
packages and other problems.
Comment 6 Warren Togami 2004-11-27 17:52:00 EST
This issue is solved.  Your other issues must be tracked in other bugs.  Thank
you for your reporting and followup.

Note You need to log in before you can comment on or make changes to this bug.